1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Alan Wake Guide

Discussion in 'Guides' started by booman, Jul 9, 2013.

  • by booman, Jul 9, 2013 at 2:16 PM
  • booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,475
    Likes Received:
    542
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    The Alan Wake series has not quite received the attention it deserves. Think of your favorite thriller movie... Alan Wake can absolutely compete with the theatrical settings and interactive elements.
    It plays just like a movie, but instead you feel like its yourself stuck in this movie battling light and dark.

    alanwake41a.png

    I won't give away any spoilers because the game will speak for its-self with the thrills and scares.
    I had a chance to try Alan Wake in Linux and it runs decent enough to deserve a guide.

    Follow my step-by-step guide on installing, configuring and optimizing Alan Wake in Linux with PlayOnLinux.

    Note: This guide applies to the GOG.com version of Alan Wake. Other versions may require additional steps.

    Tips & Specs

    To learn more about PlayOnLinux and Wine configuration, see the online manual:
    PlayOnLinux Explained

    Mint 14 32-bit
    PlayOnLinux: 4.2
    Wine: 1.5.25

    Installing Wine with PlayOnLinux

    Installing different versions of Wine is necessary for running different games because one Wine doesn't work for them all. PlayOnLinux makes it possible to download, install and test your game in all the versions of Wine until you find the right one for your speicific game.

    Launch PlayOnLinux
    Click Tools
    Click "Manage Wine Versions"

    Wine versions manager
    Select 1.5.25
    Click the right-arrow
    wine01.png

    Note: Try using stable Wine 1.8 and 1.8-staging

    Wine wizard

    Click Next
    wine02.png

    Downloading...
    wine03.png

    Extracting
    wine04.png

    Complete
    wine05.png

    Thats it! Try downloading other stable versions like 1.41

    PlayOnLinux & Wine Setup

    Launch PlayOnLinux
    Click Install
    alanwake01.png

    I was not able to find a PlayOnLinux script, but its a good idea to always search for one in the future.
    Click "Install a non-listed program"
    alanwake02.png

    Select "Install a program in a new virtual drive"
    Click Next
    alanwake03.png

    Name your virtual drive: alanwake
    No spaces
    Click Next
    alanwake04.png

    Select all three options:
    • Use another version of Wine
    • Configure Wine
    • Install some libraries
    Click Next
    alanwake05.png

    Select 1.5.25
    Click Next
    alanwake07.png

    Note: If you are running a 64-bit system, PlayOnLinux will prompt if you want to use a 64-bit or 32-bit virtual drive.
    ALWAYS SELECT THE 32-bit VIRTUAL DRIVE

    Wine Configuration

    Applications Tab
    Windows Version: Windows 7
    Click Apply
    alanwake08.png

    Graphics Tab
    Check "Automatically capture mouse in full-screen windows
    Check "Emulate a virtual desktop"
    Desktop size: 1024x768
    Click OK
    alanwake09.png

    Installing Libraries (Windows Components/DLL)

    Select the following Libraries:
    • POL_Install_xact
    • POL_Install_d3dcompiler_43
    • POL_Install_d3dx9
    • POL_Install_gdiplus
    • POL_Install_vcrun2005
    Click Next

    Libraries will download and install automatically

    Installing Alan Wake

    Click Browse
    alanwake10.png

    Navigate to your GOG.com download for Alan Wake
    Select "setup_alan_wake_1.0.0.12.exe"
    Click Open
    alanwake11.png

    Click Next
    alanwake12.png

    Checking Integrity
    alanwake13.png

    Check "Yes, I have read and accept..."
    Click Start Installation
    alanwake14.png

    Installing
    alanwake15.png

    Complete
    Don't click Launch because PlayOnLinux isn't done

    Click Exit Installer
    alanwake16.png

    Shortcut

    Select: alanwake.exe
    Click Next
    alanwake17.png

    Name the shortcut: Alan Wake
    Click Next
    alanwake18.png

    No I don't want to make another shortcut
    Click Next

    PlayOnLinux Configure

    Click Configure
    alanwake19.png

    Display Tab
    GLSL Support: disable (CRITICAL - select disable to avoid lighting issues - CRITICAL)
    Direct Draw Renderer: opengl
    Video Memory Size: the size of memory on your video card
    Offscreen rendering mode: fbo
    alanwake20.png

    Wine Tab
    Click "Windows Reboot"
    alanwake21.png

    Launch Alan Wake

    The game will automatically try to adjust the graphics settings for you. It will probably crash, and then just launch it again.

    Menu
    Click "Options"
    alanwake22.png

    Click "Graphics"
    alanwake23.png

    Resolution
    I was able to change the Resolution here
    Alan Wake ran at 16080x1050 with my hardware
    Click the resolution to adjust size of screen
    Press Enter to apply
    alanwake33.png

    Click Advanced Options
    alanwake24.png

    Graphics was set to "low" by default
    If you click the presets it will switch to custom
    Now you can adjust the advanced settings to your own preferences
    Here are the settings that worked for my card and still gave me at least 15-20fps
    The motion blur kills some of your frame rates, but I found that turning down the mouse sensitivity help reduce blur.
    alanwake25.png

    You can kill blur completely by adding the arguments "-noblur" to the virtual drive. It didn't seem to help my frame rates, but its worth a try.
    alanwake25a.png

    Conclusion:
    I was still impressed with visuals even though the settings were on low. The textures, lighting and models still looked rather nice. I read a lot about cut-scenes with no audio at WineHQ, but I never had that problem. I read about some people running Alan Wake on high with blur off, but again I didn't get smooth movement or animation.
    If this is a "must have" game... it really is playable, but be patient and keep testing with new versions of Wine in the future.

    Screenshots:

    alanwake43a.png

    alanwake44a.png

    alanwake26a.png

    alanwake27a.png

    alanwake28a.png

    alanwake30a.png

    alanwake31a.png

    alanwake34a.png

    alanwake35a.png

    alanwake36a.png

    alanwake37a.png

    alanwake39a.png

    alanwake40a.png

    alanwake42a.png
    Last edited: Jan 13, 2016
  • Categories:

Comments

Discussion in 'Guides' started by booman, Jul 9, 2013.

  1. booman
    High Quality Screenshots:

    alanwake44.png alanwake43.png

    alanwake42.png alanwake41.png

    alanwake40.png alanwake39.png

    alanwake38.png alanwake37.png

    alanwake36.png alanwake35.png

    alanwake34.png alanwake32.png
  2. booman
    I have tested with different graphical settings in Alan Wake and still get the same frame-rate. Not sure why as of yet...
    I set everything on HIGH and same 15-20 fps
    I lowered the resolution and same 15-20 fps

    So it really seems there is a conflict somewhere that prohibiting higher frame rates with this engine.
    I'll keep watching WineHQs and see if they have any more tips.
  3. jury
    Hello
    I know this is quite old thread, but generally I'm new to this game and I have problem looking like on this screen:
    http://i.imgur.com/SEF8B.jpg
    ( comes from thread: http://www.gamefaqs.com/boards/928005-alan-wake/61991702 )
    I have read some texts on how to overcome this, but nothing helped me.
    If anyone has any suggestions/experiance on how to make grass look properly or disable it completely ( I managed to do this once, but after reload of the game it returned :/ ) please share it.
    I'm playing this game thou, now I started 3 episode and like it much.
    Thanks.
  4. booman
    Yes, I experienced this problem as well with older versions of Wine.
    Try using Wine 1.8.2 or newer.
  5. jury
  6. booman
    Hmm, somehow I remember something about anti-aliasing... try disabling it in-game. Also try setting GLSL (PlayOnLinux configure/Display Tab) to disabled
  7. jury
    Thanks, tried some more settings, but it didn't help to get the grass properly looking.
    But I finally found other good solution, I can turn it completely off and it is good enough solution for me, yeah! :) dont have to stress no more on that grass ;)
  8. booman
    What was the solution? disabling anti-aliasing?
  9. jury
    No, its not possible to disable AA in this game, its strongly used as Remedy says.
    Of course you could always turn it off directly in the driver, but then as I have read in some places ( also in Remedy's official faq ) it for sure gives this 'blocky' grass and the only solution is to turn it on, what I have tried ( many different AA settings ) but I never got fixed grass.
    Then accidentally I have found out how to turn the grass completely off and have the other settings set to high.
    First I set the graphics settings to "Very low" ( this setting makes grass disappear ) and then I can go to "Custom" settings and I can set everything to High. The grass does not come back and I have everything High :)
    To make grass appear again, graphics preset setting other then "Very low" must be chosen.
  10. booman
    That is very strange. So the grass is gone completely? At least the game works for you and still looks good.
  11. jury
    Yeap, the grass is completely off :)
    And I'm so satisfied ( those landscapes are quite nice ) that I do not bother to look anymore to find a solution on fixing the grass, its OK for me.
  12. booman
    I'm the same way...
    Some bugs are very minor and tolerable. If the game plays nicely without crashing and I'm having fun... I'm ok with a few bugs.

Share This Page