1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AMD Radeon RX 5700 XT crashes/green screen

Discussion in 'Crashed!' started by Daerandin, Jul 7, 2020.

  1. Daerandin

    Daerandin Active Member

    Joined:
    Oct 18, 2013
    Messages:
    996
    Likes Received:
    178
    Trophy Points:
    43
    Location:
    Northern Norway
    Home page:
    This is not a support thread, I just figured I would share what I have learned after searching around a lot. On my current computer I have an AMD gpu, specifically the Radeon RX 5700 XT, and there are some issues with it. It is rare, and extremely random, but sometimes during gaming my screen will simply turn green and the computer locks up. I can't do anything and simply have to force reboot it. I can go for a week or more without experiencing the issue, or I might see it with just a couple of days in between. It has only happened while gaming so far.

    At first I was worried I had a defective card and I might need to get a new one. But when I started searching for this issue, I realize that a LOT of people have the same problem, even on Windows. I have seen multiple suggestions on how to fix it, and I figured it would be best to try out one thing at a time.

    For now, I have disabled Dynamic Power Management. I can't really know if it worked because of the random nature of this issue, but if I don't see this problem again for a couple of weeks then I'll assume that was the fix. I will be sure to report back here if I see the issue, or if I go for a couple of weeks without problem.

    To disable DPM, you need to add:
    radeon.dpm=0
    as a kernel parameter to your bootloader.
    booman likes this.
  2. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,813
    Likes Received:
    559
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    Nice! I like to post Linux issues and solution here as well. I'm actually happy I got the notification in my email.

    Definitely keep posting any solutions or trial-n-error you attempt! Good luck!
  3. Daniel~

    Daniel~ Chief BBS Administrator Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    8,400
    Likes Received:
    135
    Trophy Points:
    63
    Location:
    Greenwater WA
    Home page:
    any chance this is a heat/cooling problem/
    booman likes this.
  4. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,813
    Likes Received:
    559
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    Good point, is that video card overclocked?
  5. Daniel~

    Daniel~ Chief BBS Administrator Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    8,400
    Likes Received:
    135
    Trophy Points:
    63
    Location:
    Greenwater WA
    Home page:
    overclockers always think it's heat. ":O}
  6. Daerandin

    Daerandin Active Member

    Joined:
    Oct 18, 2013
    Messages:
    996
    Likes Received:
    178
    Trophy Points:
    43
    Location:
    Northern Norway
    Home page:
    I don't think that is the problem seeing that on Windows people went from crashing every time they launched a game, to now being able to play without this happening much. In any case, internal temperatures in my chassis in the same as my room temperature since I got two huge front fans. I have also been monitoring my own temperatures.

    This GPU has three temperature sensors, "edge", "junction", and "memory". Junction is apparently some kind of hotspot so it is expected to be higher than the others. When I am playing the most demanding games, all three temperatures stay well within spec. Edge temp will usually be between 65 and 70 when playing demanding games, Junction will go as high as 95-98 (AMD has said that 110 is within spec and expected for this sensor), and memory is usually somewhere between 80 and 90.

    The issues have also not surfaced while I have played some of the most demanding games. So far, the game that seems to trigger this issue the most in my case is Starcraft 2. I have also seen this issue with War for the Overworld, but only once or twice. Doom, which I've played quite a lot lately never triggers this.
    booman likes this.
  7. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,813
    Likes Received:
    559
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    Oh, I didn't realize a specific game can trigger the problem. This is interesting and kinda sounds like a driver issue.

    If you have a spare video card, you could swap it out and see if it happens to that card as well. I always have spare hardware on-hand... too bad you don't live in the U.S. I could ship a card to you.

    I know you are using Arch on this Desktop, so you can probably install an older driver if needed. I can't be heat or memory related because StarCraft 2 is a super old game. You should be able to render a 3D movie while playing it on the same system.
    Daerandin likes this.
  8. Daerandin

    Daerandin Active Member

    Joined:
    Oct 18, 2013
    Messages:
    996
    Likes Received:
    178
    Trophy Points:
    43
    Location:
    Northern Norway
    Home page:
    For now I have disabled Dynamic Power Management, which has been known to cause issues on Linux with newer AMD cards. If I don't experience problems again for a couple of weeks then I can probably assume that disabling DPM fixed it for me. Hopefully they will eventually fix the issue properly with newer drivers. As I said, they have the issue on the Mesa bugtracker, and it is a well known problem both on Windows and Linux.

    But it really does not bother me that much, as I said in the original post, I can go for more than a week without seeing the problem.
  9. Daniel~

    Daniel~ Chief BBS Administrator Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    8,400
    Likes Received:
    135
    Trophy Points:
    63
    Location:
    Greenwater WA
    Home page:
    If your happy were happy! ":O}
  10. Daerandin

    Daerandin Active Member

    Joined:
    Oct 18, 2013
    Messages:
    996
    Likes Received:
    178
    Trophy Points:
    43
    Location:
    Northern Norway
    Home page:
    Disabling DPM was not a solution, I just had another one of those green screens while playing War for the Overworld. Temperatures are usually around 70 degrees C in this game, which is far from overheating. I have a 1200W Corsair power supply, so I also doubt it would be a power issue. Perhaps I will just need to wait for the issue to hopefully be solved in a future driver at some point.

    I've been playing quite a lot for over a week without the problem, so it really is very random. But so far it has never triggered in the more demanding games. Both Doom (2016) and Doom Eternal have been running with all settings on maximum and no crashes, and I've played those games for hours.
    booman likes this.
  11. Daniel~

    Daniel~ Chief BBS Administrator Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    8,400
    Likes Received:
    135
    Trophy Points:
    63
    Location:
    Greenwater WA
    Home page:
    "This to shall pass."
  12. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,813
    Likes Received:
    559
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    I sometimes get random crashes as well in Mint. My hardware is obviously older but I try to keep my main Mint gaming station up to date. Of course this is "Mint" up-to-date which is always stable releases.

    I currently updated the kernel on 4 of my PCs and one of them started using serious CPU (60%) with the Cinnamon process. All I was doing is moving the mouse on the desktop and the CPU spiked. After some research I decided to roll back to the previous kernel and it works fine now. But that PC has an Intel Core2Duo processor. My other PCs have AMD processors.

    So who knows?

    I'm just glad your crash is weeks in-between. Seems like gaming definitely crashes it, so maybe a newer driver or kernel will fix it?

    Are there any specific errors in the log right before it happens?
  13. Daerandin

    Daerandin Active Member

    Joined:
    Oct 18, 2013
    Messages:
    996
    Likes Received:
    178
    Trophy Points:
    43
    Location:
    Northern Norway
    Home page:
    Yeah at the moment I'm just hoping that this will be fixed with a newer driver eventually. And there are no logs at all, the system really hard crashes. Sometimes I left it on for 10 minutes in this state, hoping that the log would still get written to the hard drive, but no. The system log contains only normal stuff until it just cuts off when my system freezes, and continues again with the forced reboot.

    It has to be a driver issue, since Windows users have the exact same green screen on crash.
  14. Kaitain

    Kaitain Active Member

    Joined:
    Jul 24, 2016
    Messages:
    373
    Likes Received:
    34
    Trophy Points:
    28
    AMD's firmware goofed on memory allocation - if you've got the option to set a specific memory window, e.g. 2GB or 4GB, set it to that, rather than to Auto, and the problem should go away. The green screens seem to happen whenever it tries to allocate itself more memory.
    Daerandin likes this.
  15. Daniel~

    Daniel~ Chief BBS Administrator Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    8,400
    Likes Received:
    135
    Trophy Points:
    63
    Location:
    Greenwater WA
    Home page:
    You bring such good things when you come to us K.

    How fairs our wanderer? How fairs his family?
  16. Daerandin

    Daerandin Active Member

    Joined:
    Oct 18, 2013
    Messages:
    996
    Likes Received:
    178
    Trophy Points:
    43
    Location:
    Northern Norway
    Home page:
    Thanks for the help, although I don't seem to have the option to set that in my bios. I am also not familiar with any software for changing gpu settings for AMD cards. It does not happen often these days, actually in the last 3-4 weeks or so it has only been Starcraft 2 that triggered it, and only once or twice.
  17. Kaitain

    Kaitain Active Member

    Joined:
    Jul 24, 2016
    Messages:
    373
    Likes Received:
    34
    Trophy Points:
    28
    Same issue with mine on the Raven Ridge platform - no BIOS settings for gfx memory window, so I can't test personally, it was just something mentioned at the same time as the amdgpu team were looking at random lockups for raven.

    You might also try grabbing/building the latest firmware, mesa and libdrm - mesa-git is a little ahead of the Windows driver.

    All good, still in England and no chance of travelling soon. Just spending every waking hour fixing the house up, as we've grown out of it and need to move.
    booman and Daerandin like this.
  18. Jonas Ferreira

    Jonas Ferreira New Member

    Joined:
    Oct 16, 2020
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    So, I'm a little late to the green screen party.

    I just got a rx 5600 xt and I was having these green screen issues (when gaming).

    I downloaded the unigine heaven benchmark and ran it a few times on ultra settings @ 1080p (vsync on, vsync off, tess on, tess off, aa, you name it). Every single time, green screen.

    So, I decided to monitor the gpu stats while benchmarking and I could see some things:
    1) Green screen started when VRAM temps reached ~85 degrees (C).
    2) The GPU was very quiet. I could not hear the fans kicking in.
    3) Green screen starts as green flashes, then it hangs.
    4) Green screen happen even with DPM disabled.


    A lot of people were having these issues even on windows, but somehow using the latest drivers and upgrading the vbios took care of the issue. My GPU is already running the latest vbios and I'm running amdgpu drivers (the free ones, not the proprietary amdgpu-pro). This vbios update boosted the vram clock, so I thought I could downgrade the vbios. Turns out you can't.

    So, what I did was:
    1) enabled dpm.
    2) set the gpu to run at slower pstate (so the vram clock was not running at max):
    # echo "manual" > /sys/class/drm/card0/device/power_dpm_force_performance_level
    # echo "2" > /sys/class/drm/card0/device/pp_dpm_mclk
    3) installed amdgpu-fancontrol (this puppy https://github.com/grmat/amdgpu-fancontrol)
    4) edited the conf so fans would be kicking in early (just so I could run benchmarks and check how things were doing)
    5) ran the benchmarks, vram didn't even reach 70 degrees. NO GREEN SCREEN.


    After that, I just tweaked a little the fan curves so I don't end up deaf (the gpu is loud as f. when fans are at 100%) and set dpm to auto again. With fans actually running, I'm not getting green screens anymore.

    Turns out you can tweak a lot a stuff with these cards even with the free driver. The archlinux wiki has a lot of stuff on that, even the power draw [https://wiki.archlinux.org/index.php/AMDGPU#Overclocking]

    Stay cool
  19. Daerandin

    Daerandin Active Member

    Joined:
    Oct 18, 2013
    Messages:
    996
    Likes Received:
    178
    Trophy Points:
    43
    Location:
    Northern Norway
    Home page:
    Great to hear that you found something that works for you! I'll definitely keep this in mind if I experience the problem again.

    For some reason, I have not had this happen for several weeks now. I'm also still playing the games that used to cause the green screen crash, but now everything seems to run smoothly. In my case, with a 5700 card, I never found any correlation between temperature and the crash. After all, the most demanding games I play don't trigger the issue, and benchmarks also runs just fine. However, I have updated my bios in early september, and the driver as well as gpu firmware have had several updates recently on Arch, so maybe the newer driver/firmware fixed the issue.

    If I do encounter any more crashes I will definitely report back here, and test your solutions as well. But for now, it seems to be fixed on my end.
    Jonas Ferreira likes this.
  20. Jonas Ferreira

    Jonas Ferreira New Member

    Joined:
    Oct 16, 2020
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    So.. another thing to check: System RAM
    X.M.P with auto timings & frequency, seems to work fine most of the time, but under very heavy load (CPU + GPU) I will get green flashes.
    So, I set the RAM frequency to 2666mhz (both my mobo and memories let me go way past that, but ryzen and rx5600xt are being a b. about it) and left XMP enabled. Have been benchmarking on the background and working (a bunch of docker containers, intellij and some heavy scala stuff) on the foreground for about 4hs straight, not a single green flash.

    So, fan curves + dram settings.

Share This Page