1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dragon Age Origins Guide

Discussion in 'Guides' started by booman, Dec 19, 2015.

  • by booman, Dec 19, 2015 at 7:10 PM
  • booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,269
    Likes Received:
    527
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    daorigins116.jpg

    Dragon Age: Origins is an party-based action RPG. Choose to begin as an Elf, Human or Dwarf and train to become a Gray Warden. Interact in a detailed story as you rid the world of Darkspawn, ghosts, dragons and more.

    daorigins96.jpg

    Follow my step-by-step guide on installing, configuring and optimizing Dragon Age: Origins in Linux with PlayOnLinux.

    Note: This guide applies to the Origin version of Dragon Age: Origins. Other versions may require additional steps.

    Tips & Specs:

    To learn more about PlayOnLinux and Wine configuration, see the online manual: PlayOnLinux Explained

    Mint 17.2 64-bit
    PlayOnLinux: 4.2.9
    Wine: 1.7.51-staging

    Wine Installation

    Click Tools
    Select "Manage Wine Versions"
    wine01.png

    Look for the Wine Version: 1.7.55-staging
    Select it
    Click the arrow pointing to the right
    wine02.png

    Click Next

    Downloading Wine
    wine04.png

    Extracting

    Downloading Gecko
    wine05.png

    Installed
    wine06.png

    Wine 1.7.55-staging is installed and you can close this window

    Download OriginSetup.exe

    Go to: download.dm.origin.com/origin/live/OriginSetup.exe
    Navigate to your desktop
    Click Save
    daorigins01.png

    PlayOnLinux Setup

    Launch PlayOnLinux
    Click Install
    daorigins02.png

    Click "Install a non-listed program"
    daorigins03.png

    Click Next

    Select "Install a program in a new virtual drive"
    Click Next
    daorigins05.png

    Name your virtual drive: daorigins
    Click Next
    daorigins06.png

    Check all three options:
    • Use another version of Wine
    • Configure Wine
    • Install some libraries
    Click Next
    daorigins07.png

    Select "Wine 1.7.55-staging"
    Click Next
    daorigins08.png

    Select "32 bits windows installation"
    Click Next
    daorigins09.png

    Wine Configuration

    Applications Tab
    Windows version: Windows 7
    Click Apply
    daorigins10.png

    Graphics Tab
    Check "Automatically capture the mouse in full-screen windows"
    Check "Emulate a virtual desktop"
    Click OK
    daorigins11.png

    Installing Packages (Libraries, Components, DLL's)

    Check the following packages:
    • POL_Install_corefonts
    • POL_Install_d3dx9
    • POL_Install_physx
    • POL_Install_tahoma
    • POL_Install_vcrun2005
    • POL_Install_vcrun2008
    • POL_Install_vcrun2010
    • POL_Install_vcrun2012
    Click Next
    daorigins12.png

    Click Browse

    Installing Origin Client

    Navigate to your Desktop
    Select OriginSetup.exe
    Click Open
    daorigins14.png

    Click Next Again

    Uncheck all options:
    Click Install
    daorigins17.png

    Check "I have read and accept..."
    Click OK

    At this point the client will try to launch, but will crash

    Killing Origin Process

    Alt+Tab to PlayOnLinux
    Click Configure
    daorigins20.png

    Wine Tab
    Click "Kill Processes"
    daorigins21.png

    PlayOnLinux Shortcut

    Select Origin.exe
    Click Next
    daorigins22.png

    Name the shortcut: Dragon Age: Origins
    Click Next
    daorigins23.png

    Select "I don't want to make another shortcut"
    Click Next
    daorigins24.png

    Back to Configure

    General Tab
    Wine version: 1.7.55-staging
    daorigins25.png

    Note: Click the + to download other versions of Wine. Click the down arrow to select other versions of Wine

    Display Tab
    GLSL: disable
    Video memory size: Enter the amount of memory your video card/chip uses
    Strict Draw Rendering: enable
    daorigins26.png

    Note: Enabling Strict Draw Rendering fixes the choppy cutscenes

    Close Configure

    Origin Directory Permissions

    If you launch Origin it will crash every time
    This is because of the In Game Overlay
    We have to do this manually by renaming some files
    But, the Origin folder is locked

    Go to the Origin Directory
    Path: /home/username/.PlayOnLinux/wineprefix/Origin/Drive_C/Program Files/
    Right click
    Select Properties
    daorigins27.png

    Click Dropdown next to "Owner"
    Select "Create and delete files"
    Click "Apply Permissions to Enclosed Files"
    Click Close
    daorigins28.png

    Rename:
    igoproxy.exe
    igoproxy64.exe

    To:
    igoproxy-old.exe
    igoproxy64-old.exe
    daorigins30.png

    Note: When Origin updates, you will need to repeat these steps

    Launching Origin

    Back to PlayOnLinux
    Select Origin
    Click Run
    daorigins31.png

    Note: Click Debug to see errors and bugs

    Login to Origin
    daorigins32.png

    Note: Check "Remember password" to make launching games easier

    Turn off In Game Overlay
    Click Origin Menu
    Go to "Application Settings"
    Click "Origin In Game"
    Uncheck "Enable Origin In Game"

    Note: In Game Overlay causes Dragon Age to crash at launch

    Installing Dragon Age: Origins

    Select Dragon Age: Origins
    Click Download
    daorigins34.png

    Uncheck "Create start menu shortcut"
    Uncheck "Create desktop shortcut"
    Click Continue
    daorigins35.png

    End User License Agreement
    Check "I have read..."
    Click Continue
    daorigins36.png

    Note: Origin may crash when Dragon Age is done downloading

    Back to PlayOnLinux

    Dragon Age and Config Shortcuts

    Select Dragon Age: Origins
    Click Configure again

    General Tab
    Click "Make a new shortcut in this virtual drive"
    Select DAOriginsConfigure.exe
    daorigins39.png

    Name it: Dragon Age Configure

    Select daorigins.exe
    Name it: Dragon Age: Origins
    daorigins41.png

    Select "I don't want to make another shortcut"
    Click Next to finish

    Dragon Age Config

    Select Dragon Age Config
    Click Run
    daorigins44.png

    Adjust:
    • Resolution
    • Aspect Ratio
    • Graphics Detail
    • Anti-Aliasing
    • Texture Detail - SET TO MEDIUM!
    • Play in Full-Screen mode
    • Verticaly Sync
    • Frame-Buffer Effects
    • Disable Mutiple Render targets
    • Disable Aspect Ratio correction
    • Disable Intro Movies
    daorigins45.png

    Note: Texture Quality has to be set on "Medium" to reduce Memory Leaks and artifacts

    Save Settings
    Click Dragon Age: Origins Menu
    Click Save Settings
    daorigins46.png

    Launching Dragon Age: Origins

    Select Dragon Age: Origins
    Click Run
    daorigins47.png

    In Game Options
    Click Options
    daorigins48.png

    Click Video Tab
    Adjust Graphics settings
    Click OK
    daorigins49.png

    Conclusion:
    Once I figured out the Origin In Game Overlay was causing Dragon Age Origins to crash at launch, it ran perfectly fine. Performance is great on my GeForce 550 Ti.
    With texture quality on high I experienced missing textures, graphical artifacts, memory leaks and super low FPS. The main solution was to set textures on Medium and all of those symptoms were fixed. Unfortunately the textures aren't as crisp and beautiful, but its better than not playing at all.

    Gameplay Video:



    Screenshots:
    daorigins80.jpg

    daorigins82.jpg

    daorigins115.jpg

    daorigins113.jpg

    daorigins110.jpg

    daorigins105.jpg

    daorigins102.jpg
    Last edited: Mar 23, 2018
    mrdeathjr28, Marlhin and vashin like this.

Comments

Discussion in 'Guides' started by booman, Dec 19, 2015.

  1. Marlhin
    Good guide as always and an absolutely great game!
    booman likes this.
  2. mrdeathjr28
    Very good guide

    However in my case use high quality in textures and works good, however graphic detail stay on medium



    in 0:38 second appears graphic settings used

    :)
  3. booman
    Thanks guys! It took some research and trial-n-error to get Dragon Age: Origins running...
    This is definitely an immersive Bioware game!
    Sucks that I have to play with textures on medium, but it plays nicely!
  4. Mhancock2
    Ok I am back again with another question. I am trying to install Dragon age. I did the guide. When I click on it it starts and goes to the Dragon age screen. Then an error pops up that appears to be a wine error. Error I utilizing physic. Please visit nvidia.com/physx for updated drivers. I hit Ok and it crashes.
    booman likes this.
  5. booman
    Ok, the first thing I always suggest is trying a newer version of Wine since this guide is a bit old.

    Definitely try a "staging" version of Wine as well.

    You might be able to install the package: physx
    But it has to be installed before you start installing the game.
  6. Mhancock2
    I got it figured out. What I did was under the wine config, install components that is an option. I checked it. It installed and the game started working. Thanks for your help.
  7. booman
    Great!
    Do you know which components it installed?
  8. Mhancock2
    That physx component. It was listed as a cmponent I could installed. I just clicked it and installed it. Simple as that.
  9. booman
    Hmm, physx component isn't in my guide. I'll add it.
    Thanks for confirming!
  10. Mhancock2
    Ok I have searched and haven't found anything yet. How about Dragon Age 2?
  11. Mhancock2
    I have got it installed. I click on the Icon and the start screen pops up but then nothing else ever happens. The game never loads.
  12. ssj2songohan
    got an error while installing PhysX:
    Code:
    0055:err:winediag:ODBC_LoadDriverManager failed to open library "libodbc.so.1": libodbc.so.1: cannot open shared object file: No such file or directory
    
    Running on OpenSuSE Leap 15.0
    Code:
    Wine Prefix Arch: 32 Bit
    Wine Version: 3.16
    
    GLSL: default
    Direct Draw: default
    Video mem size: 4096
    Offscreen: default
    Render Target: default
    Multisampling: default
    Strict Draw: default
    
    solved the problem with linking some libraries
    Code:
    locate libodbc | grep "/usr/lib"
    ...
    /usr/lib/libodbc.so
    /usr/lib/libodbc.so.2
    /usr/lib/libodbc.so.2.0.0
    /usr/lib/libodbccr.so
    /usr/lib/libodbccr.so.2
    /usr/lib/libodbccr.so.2.0.0
    /usr/lib/libodbcinst.so
    /usr/lib/libodbcinst.so.2
    /usr/lib/libodbcinst.so.2.0.0
    ...
    /usr/lib64/libodbc.so
    /usr/lib64/libodbc.so.2
    /usr/lib64/libodbc.so.2.0.0
    /usr/lib64/libodbccr.so
    /usr/lib64/libodbccr.so.2
    /usr/lib64/libodbccr.so.2.0.0
    /usr/lib64/libodbcinst.so
    /usr/lib64/libodbcinst.so.2
    /usr/lib64/libodbcinst.so.2.0.0
    ...
    
    ln -s /usr/lib64/libodbc.so /usr/lib64/libodbc.so.1
    ln -s /usr/lib/libodbc.so /usr/lib/libodbc.so.1
    booman likes this.
  13. booman
    Very nice! So strange that Physx needed linked libraries for libodbc.so.1 when that is a Linux library not a Windows one.
    Thanks for your post!

Share This Page