1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Duelyst - Installation - Help!

Discussion in 'PlayOnLinux' started by w1tchfind3r, Feb 1, 2016.

  1. w1tchfind3r

    w1tchfind3r New Member

    Joined:
    Feb 1, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hello guys!

    I am new to this forum and Linux in general (Linux Mint in my situation).
    The thing I am asking of you is the following: Can you help me install Duelyst on Linux Mint? I don't know where to start and what to do. I have already downloaded PlayOnLinux, but I do not understand exactly how to use it.

    To be more precise, I am asking the following three questions:
    1. Which version of Wine should I install and use?
    2. How should I configure it to work properly?
    3. What kind of packages (libraries, components, DLL's) should I install?

    I am looking forward to your answers.
    Thank you in advance!
  2. Aryvandaar

    Aryvandaar Active Member

    Joined:
    Jun 21, 2014
    Messages:
    304
    Likes Received:
    28
    Trophy Points:
    28
    Location:
    Norway
    1. I always use the newest wine version first (32-bit) then if I have problems I go a version down.
    2. Best is to keep it at default Windows XP. Besides that, you can set it to emulate a virtual desktop and capture the mouse. I always capture the mouse, but I don't always create a virtual desktop. Go to display tab and set how much video ram your graphics card have.
    3. That depends on the game. If you install a game then go in C:\program files (x86)\steam\steeamapps\common\<game name>\ then depending on folder structure you have to find a folder called _commonredist_ that contains directx, sometimes vcrun, sometimes dotnet.

    Games doesn't always have all the dependencies in that folder, because it's assumed that some components windows already have. So sometimes it requires a bit of testing and a bit of searching around.
  3. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,727
    Likes Received:
    552
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    Welcome to the forum w1tchfind3r! Great to have you here!

    Normally when I test games I search at www.WineHQ.org, but since there is no Duelyst entry you might have a lot of work to do because nobody has tested it in Wine yet. I can't even find system specs for Duelyst.
    I may have to test it myself, since its free-to-play. Also note that some games work as beta and then stop working as they patch it, you might want to wait until its official release before testing.
    Below are steps I use to test a game with PlayOnLinux manual instalaltion

    Manual Installation:

    • Launch PlayOnLinux
    • Click Install
    • Click “Install a non-listed program”
    • Click Next
    • Select “Install in a new virtual drive”
    • Name your virtual drive (no spaces)
    • Select all three options:- Use another version of Wine- Configure Wine- Install some libraries
    • Select Wine version
    • Set Windows version
    • Graphics Tab:- check “automatically capture mouse...”- check “emulate a virtual drive”- Desktop size: 1024x768
    • Click Ok
    • Select libraries to install
    • Standard Libraries:- core fonts- d3dx9- dotnet 40- gdiplus- tahoma- vcrun20xx
    • Browse to downloaded game or client
    • Install game or client
    • If client, download game
    • Setup PlayOnLinux shortcut
    • PlayOnLinux Configure:
      - Display Tab
      - Set Memory size
    • Launch Game with "Debug" not "Run"
    • If game crashes, check debug for library errors
    • Test with other versions of Wine
  4. w1tchfind3r

    w1tchfind3r New Member

    Joined:
    Feb 1, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for your guides guys!

    @booman I have tried what you suggested, but for some reason when I try to install the game, it says that it is not supported for Windows XP. I started from the beginning again and selected Windows 7 as my version, but it still said that I have Windows XP and I need a newer version of Windows. Why is that?

    Also, I get a strange error code during an installation. Some kind of files mismatch:

    Error in POL_Download_Resource
    POL_Download_Resource - MD5 sum mismatch ! (1 attempt))

    I do not know what exactly causes this error.

    My Wine version is 1.9.2., 32bit installation.

    If it is too much trouble for you guys, I will wait for their stable release of the game. I am pretty sure they will release it for Linux as well, at some point at least.
  5. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,727
    Likes Received:
    552
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    Start over again and make sure to set Windows 7 from the beginning.
    Try using Wine 1.8 because its stable. I know its not the newest version, but its definitely stable.

    At what point do you get the "Error in POL_Download_Resource"?
    Is it when you are installing packages?

Share This Page