1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Age Of Wushu Guide

Discussion in 'Guides' started by booman, Aug 8, 2014.

  • by booman, Aug 8, 2014 at 1:44 PM
  • booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,475
    Likes Received:
    542
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    Everything you want from Anime in a single game! Age of Wushu is a massive online multiplayer RPG with loads of character development, massive environments and classic Kung Fu moves all in Ancient China. Spend hours building up skills, exploring or socializing with NCP's and PVP characters.

    wushu85.png

    wushu87.png

    Follow my step-by-step guide on installing, configuring and optimizing Age of Wushu in Linux with PlayOnLinux.

    Note: This guide applies to the Snail Games version of Age of Wushu. Other versions may require additional steps.

    Tips & Specs:

    To learn more about PlayOnLinux and Wine configuration, see the online manual: PlayOnLinux Explained

    int 17 64-bit
    PlayOnLinux: 4.2.4
    Wine: 1.5.19

    Wine Installation

    Click Tools
    Select "Manage Wine Versions"
    wine01.png

    Look for the Wine Version: 1.5.19
    Note: Try using stable Wine 1.8 and 1.8-staging
    Select it
    Click the arrow pointing to the right

    wine02.png

    Click Next

    Downloading Wine
    wine04.png

    Downloading Gecko
    wine05.png


    Installed
    wine06.png

    Wine 1.5.19 is installed and you can close this window

    Age of Wushu Downloader

    Go to: www.ageofwushu.com
    Click Download
    wushu01.png

    Download full game by clicking "Click here to download"
    Or Download separate .cab files to a folder on your desktop
    wushu02.png

    Save Ageofwushu_download.exe to your desktop
    wushu04.png

    PlayOnLinux Setup

    Launch PlayOnLinux
    Click Install
    wushu05.png

    Click "Install a non-listed program"
    wushu06.png

    Click Next

    Select "Install a program in a new virtual drive"
    Click Next
    wushu08.png

    Name your virtual drive: ageofwushu
    Click Next
    wushu09.png

    Select all three options:
    • Use another version of Wine
    • Configure Wine
    • Install some libraries

    Click Next
    wushu10.png

    Select Wine 1.5.19
    Click Next

    Select "32 bits windows installation"
    Click Next
    wushu13.png

    Wine Configuration

    Applications Tab
    Windows Version: Windows 7
    Click Apply
    wushu14.png

    Graphics Tab
    Check "Automatically capture the mouse in full-screen windows"
    Check "Emulate a virtual desktop"
    Desktop Size: Set to match the resolution of your Linux desktop
    Click OK
    wushu15.png

    Installing Components (Libraries/Packages/DLL's)

    Check the following:
    • POL_Install_corefonts
    • POL_Install_d3dx9
    • POL_Install_gdiplus
    • POL_Install_physx
    • POL_Install_registered_fonts
    • POL_Install_tahoma
    • POL_Install_wininet
    • POL_Install_xact
    Click Next
    Note: All libraries will automatically download and install

    Installing Age Of Wushu

    Click Browse
    wushu16.png

    Navigate to your desktop
    Select "AgeofWushu_download.exe"
    Click Open
    wushu17.png

    Click Next

    Age of Wushu launcher will run
    Click Start to begin downloading (10 GB)
    wushu19.png

    Downloading...
    wushu20.png

    Installing Age of Wushu

    Click Next

    Select "I accept the terms..."
    Click Next

    click Next

    Click Install

    Installing

    Uncheck "Launch Now"
    Click Finish
    wushu26.png

    PlayOnLinux Shortcut

    Select "fxlaunch.exe"
    Click Next
    wushu27.png

    Name your shortcut: Age Of Wushu
    Click Next
    wushu28.png

    PlayOnLinux Configure

    Back to PlayOnLinux
    Select "Age Of Wushu"
    Click Configure
    wushu29.png

    General Tab
    Wine Version: 1.5.19
    wushu30.png

    Note: Click the + to download other versions of Wine. Click the down-arrow to select other versions of Wine.

    Display Tab
    Video Memory size: Select the amount of memory your video card/chip uses
    wushu31.png

    Close Configure

    Launching Age of Wushu

    Back to PlayOnLinux
    Select Age of Wushu
    Click Run
    wushu32.png

    Note: Click Debug to see console errors and bugs

    Click Confirm
    wushu33.png

    Select a server
    Click Confirm
    wushu34.png

    Updating/Settings

    After selecting a server Age of Wushu will probably download an update
    wushu35.png

    Click Settings
    • Uncheck Windowed Mode for fullscreen
    • Adjust Resolution
    • Adjust volumes
    wushu36.png

    Click Play
    wushu37.png

    Loading...
    wushu38.png

    Login
    Click Enter Game
    wushu39.png

    Select Character
    wushu40.png

    Optimization

    Press Esc in-game
    Click Video Options
    wushu41.png

    Use presets on the left
    Or
    Adjust settings manually
    wushu42.png

    Rule of Thumb:
    High settings = More detail, lower frame rates
    Low settings = Less detail, higher frame rates

    The Video Options has a great Frame Counter.
    As you increase the settings watch the frame rate.
    Anything below 20 will stutter a lot.

    Conclusion:
    I originally tested Age of Wushu with Wine 1.6.2 and newer version, but kept getting a pop-up error "Speed Up" and it was very annoying. Luckily I found Wine 1.5.19 runs perfectly!
    Also, the game refuses to do high resolutions unless you set the virtual desktop first. So I set mine for 1680x1050 and it played fullscreen just fine. What a beautiful game! I was able to crank the depth of view really high on my GeForce 550 Ti and see mountains and buildings really far away.

    Gameplay Video


    Screenshots:
    wushu100.png

    wushu99.png

    wushu98.png

    wushu95.png

    wushu92.png

    wushu88.png

    wushu81.png
    Last edited: Apr 24, 2016

Comments

Discussion in 'Guides' started by booman, Aug 8, 2014.

  1. mrdeathjr28
    Good guide as always and have very nice to see (especially water shader)

    :)
  2. Romulo Neves
    Hi, Thanks for the guide. But I'm having problems :p
    I get "error in main, age of wushu blocked" just when I run from playonlinux. Then the left panel (news, I'm guessing) is blank. When I hit Play, a window in game pops up: "SGP initialize failed".
    Any ideas?
    Thanks
  3. booman
    Welcome to the forum!
    I can't believe someone is playing Age of Wushu... this is GREAT!

    Can you give me a bit more information?
    • Distro
    • Video card/chip
    • PlayOnLinux version
    • Wine version
    Are you able to run any other games in Linux?
  4. Romulo Neves
    Hi booman, thanks for replying.
    Yes, I've played the game for a day before (on windows), and for a complete newbie like me the community there was REALLY welcoming.

    I'm running mint 17 64bits.
    Graphic card is Nvidia GTS 250
    Playonlinux version 4.2.5
    Wine version 1.5.19 as ordered in tut.

    Yes, I can run Lineage 2 and WoW already.
  5. booman
    SGP is an anti-cheat process installed by Age Of Wushu: Snail Game Protect
    I wonder if this is new? I didn't originally have any problems with it.
    Definitely try using the Wine Manager in PlayOnLinux, download Wine 1.7.47 and Wine 1.7.47staging
    Then go to Configure and change from Wine 1.5.19 to 1.7.47 and launch again.
  6. Dimebag
    Hi, @booman! I just tried to install Age of Wulin (the Wushu in Europe) and I run across an error: please check the display equipment, confirmed open 3d acceleration!

    Can you please help me make it work? I a beginner in linux and don't know where to start.

    I am running Ubuntu 64bits
    on an ASUS UX32VD with nVidia 620M
    Wine version 1.6.19
    Playonlinux 4.2.2
  7. Dimebag
    Wine 1.5.19* won't let me edit
  8. booman
    Sounds like you don't have proper video drivers installed.
    What distro are you using and what video card/chip do you have?
  9. Dimebag
    Ubuntu 15.04 LTS / nVidia 620M (dedicated card in laptop)

    I did manage to get a few steps further by re-following carefully the steps in this guide. I now managed to get past the "start game" button but the client freezes/crashes in the screen before login.

    Any idea? If it's possible to talk in private, it should be more efficient.
  10. booman
    Are you able to play any other games in Ubuntu 15.04?

    Lets keep this public so others can read about your experience.
    I haven't tested Age of Wushu in a long time, but you may want to download a newer version of Wine like: 1.7.53 or even 1.7.53-staging
    Then test again
  11. Dimebag
    I have tried with 1.7.53 and it still gets stuck in the same place. I do have two ideas of where it might go wrong:
    - is maybe the EU version a bit different?
    - the nvidia driver may not be well configured. I have followed this guide: http://xmodulo.com/install-configure-nvidia-optimus-driver-ubuntu.html
    Do you know of any way to verify once and for all if the nvidia is installed correctly?
  12. Dimebag
    Oh and no, haven't played any other game. It's actually a fresh install of ubuntu
  13. booman
    You might be right about the EU version, but I'm not sure because I can't test it myself. I also don't have an Intel/Nvidia graphics chips.
    I suggest trying some free-to-play Steam games first to make sure the Nvidia proprietary drivers are installed correctly. There has to be a way to switch between the Intel and Nvidia chips.

    Did all of the commands for the Optimus driver work?
    Were you able to switch to Nvidia with
    Code:
    prime-switch nvidia
    Or can you use the Prime Indicator Package?
  14. Dimebag
    I don't know what else to try. Tried all sorts of things found on google, nothing worked. Finally purged everything nvidia related and did fresh install of nvidia-current. Nothing changed. Atm:

    Using nvidia-settings I can't see the graphics card and the command line output is:
    ** Message: PRIME: Requires offloading
    ** Message: PRIME: is it supported? no

    Doing lspci | grep VGA I only see the intel.
    prime-switch nvidia doesn't work
  15. booman
  16. Dimebag
    I can't seem to make prime/optimus or bumblebee work. I see some post saying optimus is not supported by nvidia on ubuntu, and another one saying the exact opposite. I have found several different ways to reinstall the drivers. All this hassle makes me switch back to windows and just run ubuntu in a VM if needed.

    Though I do have to ask: do I NEED nvidia to make the game work? I remember using ASUS power4gear on windows (which i assume is the same thing as optimus) and it worked fine; could feel how the powersaving option was making the system slower BUT the game still worked.
  17. booman
    Yup, this is one of the downsides to Linux. Its not even Linux's fault, instead its driver support by Nvidia, Intel and AMD.

    There are two more things we can try.
    Since you want to play games in Linux video drivers are VERY imporant and once they are working everything should play happily as long as your GPU is fast enough for most games. At least you don't have an AMD video card. Those drivers are even worse.
    One unfortunate thing about 64-bit Distros is that they don't automatically install the 32-bit libraries so you can play games. The computer world is turning in a 64-bit world, but there are still 100 thousand programs that can only run in 32-bit.
    So you will need to install the 32-bit libraries manually in the Terminal

    Ubuntu 14 32-bit libraries:
    Code:
    sudo dpkg --add-architecture i386
    Press Enter
    Code:
    sudo apt-get update
    Press Enter
    Code:
    sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386
    Press Enter

    That still may not be enough libraries, so if you still have problems here is how to install ALL of them.

    Ubuntu 32-bit Instructions:
    Code:
    sudo dpkg --add-architecture i386; sudo apt-get update
    Press Enter

    Code:
    sudo apt-get install libasound2:i386 libasound2-plugins:i386 libfontconfig1:i386 lib32nss-mdns libgnutls26:i386 libxslt1.1:i386 libxcursor1:i386 libxcomposite1:i386 libosmesa6:i386 libopenal1:i386 libmpg123-0:i386 libldap-2.4-2:i386 liblcms2-2:i386 libgstreamer0.10-0:i386 libgstreamer-plugins-base0.10-0:i386 libgsm1:i386 libxinerama1:i386 libxi6:i386 libv4l-0:i386 libsane:i386 libudev1:i386 libxml2:i386 libcups2:i386 libxrandr2:i386 libice6:i386 libsm6:i386
    Press Enter

    I honestly recommend Linux Mint 17 instead of Ubuntu. Its more like Windows and includes stable driver installation (at least for my single Graphics Card).
    And you can easily install 32-bit libraries through the software installer.
  18. Dimebag
    Hi. Been a long time because I kinda gave up on the idea. The i386 drivers were already installed and still doesn't work. I give up on trying to make it work on ubuntu. I will give Mint a try later, when I will have more time to mess around.

    I have talked with other people that made it work with your guide so there's no doubt it's spot-on. Thank you for the help and will try again in a few months probably.

    Cheers!
  19. booman
    No problem
    Feel free to post your experience and solutions.

Share This Page