1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Guide] Final Fantasy XIV: A Realm Reborn on GNU/Linux

Discussion in 'Guides' started by allenskd, Feb 1, 2015.

  • by allenskd, Feb 1, 2015 at 2:31 AM
  • allenskd

    allenskd Active Member

    Joined:
    Feb 5, 2014
    Messages:
    510
    Likes Received:
    51
    Trophy Points:
    28
    [​IMG]

    Final Fantasy XIV: A Realm Reborn is a Massive Multiplayer Online Game (MMO) by Square Enix. As you might expect the world of FFXIV is filled incredibly amazing music that revolves around old themes, and classes such as Dragoons, Summoners, White Mages, Black Mages, Ninja, Botanist, etc.

    [​IMG]

    I'll be breaking down this guide into several sections.


    Sections

    1. Overview

    The WINE I'm providing has CSMT patches integrated. I also merged the patches that were made a year ago to solve the user interface flickering issue. Originally this guide was going to include PlayOnLinux instructions, but it became apparent that creating a shortcut in POL is an uphill battle, for some reason it didn't want to create a simple shortcut.

    Winetricks is required to be installed before using this guide.




    2. Getting it running

    UPDATE:

    Due to taking down the virtual private server (VPS) soon I've taken a snapshot of the archives I've uploaded related to WINE. Issue has been solved. Leaving link as backup either way.

    You can find it all here


    First, I'm going to assume that you have downloaded the game either through Virtual Box or having a Windows partition. This guide will not cover the installation phase of the game. However, you are most welcome to create a new thread on GamersOnLinux forums.

    Download the binaries here, you can also download the source here.

    After downloading the binaries:

    Create the following folder
    Code:
    
    $ mkdir -p ~/WINE/binaries/x86
    $ cd ~/WINE/binaries/x86
    $ wget http://thehumble.ninja/pelican_backup/assets/archives/wine-1.7.24-FFXIV-CSMT.tar.xz
    $ tar xfv wine-1.7.24-FFXIV-CSMT.tar.xz
    
    Temporarily we will append WINE to the PATH environment variable.

    Type this to get the current directory you are in.
    Code:
    $ cd wine-1.7.24-FFXIV-CSMT/bin; pwd
    
    Copy/Paste the result here, example:
    Code:
    $ export PATH=$PATH:/home/$USER/WINE/binaries/x86/wine-1.7.24-FFXIV-CSMT/bin
    
    Now, it's time to install all the software required to run Final Fantasy XIV.
    Code:
    $ export WINEPREFIX=/home/$USER/WINE/bottles/FFXIV; export WINEARCH=win32
    $ winetricks d3dx9 devenum ie8 quartz wininet winhttp xact_jun2010 wmp10
    
    It's important that the applications be installed, do not skip any of them.

    3. Let's launch it!

    Once it's done, go to the installation folder of Final Fantasy XIV. For example, my installation folder is this one ("/media/david/Usagi/FINAL FANTASY XIV - A Realm Reborn/"). You will need to enter the boot folder, thus making it "/media/david/Usagi/FINAL FANTASY XIV - A Realm Reborn/boot"

    Launch the game!
    Code:
    $ cd /PATH/TO/YOUR/FFXIV INSTALLATION/boot/
    $ wine ffxiboot.exe
    
    If it doesn't let you click on the EULA, don't worry.

    Edit the EULA file:

    Code:
    nano ~/my games/FINAL FANTASY XIV - A Realm Reborn/FFXIV_BOOT.cfg
    
    Turn

    EulaAgreement 0

    into

    EulaAgreement 1

    Now, let's just forget about the game for a moment. If you are following the instruction to install FFXIV without PlayOnLinux, do these steps:

    Code:
    $ wine regedit
    
    Follow the steps: We are going to create some keys here.

    In a nutshell, we just create the folder (key) in HKCU/Software

    The key will be named “Direct3D”

    The string keys within Direct3D will be the following
    Code:
    CSMT = enabled
    StrictDrawOrdering = disabled
    
    Here are some images so you get the idea!

    [​IMG] [​IMG] [​IMG] [​IMG] [​IMG] [​IMG]
    Once everything is set, run the game again.

    Code:
    
    $ wine ffxivboot.exe
    
    [​IMG]
    Log in, and play to your hearts content!


    Let me simplify this for you, my dear reader! Let's create a shell script
    Code:
    
    $ mkdir ~/WINE/shortcuts
    
    Using your favorite editor, create a file called FFXIV

    Code:
    #!/bin/sh
    
    export WINEPREFIX=/home/david/WINE/bottles/FFXIV
    # COMMENT IF THE GAME IS FAILING TO LAUNCH
    export WINEDEBUG=-all
    
    # UNCOMMENT THESE LINES IF YOU USE NVIDIA DRIVERS
    #export LD_PRELOAD="libpthread.so.0 libGL.so.1"
    #export __GL_THREADED_OPTIMISATIONS=1
    
    WINE=/home/david/WINE/binaries/x86/wine-1.7.24-FFXIV-CSMT/bin/wine
    
    $WINE "/media/david/Usagi/FINAL FANTASY XIV - A Realm Reborn/boot/ffxivboot.exe"
    
    Code:
    $ chmod +x ~/WINE/shortcuts/FFXIV
    
    From now on you can just type
    Code:
    $ ~/WINE/shortcuts/FFXIV
    
    Important note:


    After the game launches, be sure to kill ffxivlauncher.exe in the terminal. The process does not close completely and it hogs the CPU.


    Simply type

    Code:
    $ killall ffxivlauncher.exe
    
    Screenshots (these were all taken while playing on Linux)

    [​IMG]

    [​IMG]

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    Last edited: Apr 5, 2016
    mrdeathjr28 likes this.
  • Categories:

Comments

Discussion in 'Guides' started by allenskd, Feb 1, 2015.

  1. booman
    Awesome Guide Allen! I moved it to the Guides forum and now its on the front page
  2. allenskd
    Thanks booman!

    I've updated the archives, they are now being provided from my personal site.

    This means you can just simply use wget or curl.
  3. allenskd
    Updated guide.

    Introduced the variable $USER in the path instructions. I hope that it's compatible with the different shells out there.
  4. booman
    Are you able to edit this guide?
  5. allenskd
    Yes! :) I did a while ago.
  6. booman
    awesome
    nice screenshots for the registry
    I can't believe games still need IE8 to run with Wine.
    mrdeathjr28 likes this.
  7. mrdeathjr28
    Yes some titles still need IE and still lacks IE wine and other functions related but with more time this improve
  8. allenskd
    It's not that the use IE8, they don't need the browser in general. What they want is the libraries Internet Explorer uses or provides. Thus making the application dependent of it.
  9. booman
    Interesting the only IE8 provides libraries for something like a game.
    I would think windows its-self would provide these libraries.
  10. allenskd
    Screenshots have been added. I played on fullscreen yesterday, I know it's hard to notice the differences between Windows and Linux, haha.

    Still, if in doubt, watch the video!
  11. booman
    Is this an online MMO?
    I thought all Final Fantasy games were turn-based, but this one seems like an action RPG.
  12. allenskd
    Yes, it's an MMO. (Hey... I wrote that in the first paragraph!)

    Final Fantasy have had three MMOs

    Final Fantasy 11
    Final Fantasy 14 (defunct)
    Final Fantasy 14: A Realm Reborn (practically, it's a revamp of what was 14 made better. FF14 had a lot of game design problems.)
  13. booman
    Looks pretty cool, thanks for doing a post on another MMO
    I've done a few and found that they break once-in-a-while with updates.
    Wine seems to handle them well.
    Nice screenshots by-the-way

    Why is there so many buttons and text on the screen?
    It looks a bit confusing
  14. BurgerJerk
    Hey Gamers On Linux Community! This game was honestly the only one keeping me from completely converting to Linux so this is really great to see. I do have one question though, would I be able to apply this same guide while also using Steam? I purchased the steam version of FF XIV ARR so if I can do that then I will for sure be getting rid of my Windows 8 partition and just using a VM instead.
  15. allenskd
    Hey, welcome!

    As far as I know all the Steam client does is download the standalone launcher with a few flags enabled. (like launching ffxivboot.exe with -issteam flag). Honestly, I bought the game before it came to Steam. It should NOT carry any differences in terms of code.

    As for applying the game on Steam. Yes, you can. However for me to help you it'd be a little bit difficult in this section as it's just a comment section. Start a new thread here: http://www.gamersonlinux.com/forum/categories/windows-compatibility-layers-wine-crossover.4/ and I'll try my best to give you a quick way to do it.

    As for getting rid of windows, I just did that this weekend, haha. I got Final Fantasy 13 running, FFXIV, Child of Light, Trails in the Sky, and so on. Although I'm not a HUGE gamer anymore, I'm playing less and less.
  16. BurgerJerk
    Hey that is great news. This week my time is a bit limited with work; I might not have a huge amount of time to dedicate to this project till next week. Until then I will try my best to stay in contact with you as soon as I am able too.
  17. darker00
    Hey guys, I tried to install FFXIV on Ubuntu, Elementary OS and Mint. Before I start, I install winetricks without wine, then I follow your guide point per point, but the launcher always says an HTTPS error linked to IE8.
    In fact IE isn't loading pages which require https (it displays couldn't connect to website), they works only if they use the standard http protocol.
    I tried with other versions of wine and they works without problem with IE8 on https and FFXIV launcher (but the game is very laggy without CSMT patch).
    I noticed your wine doesn't ask for installing gecko and mono. I tried with a manual install, but it seems wine doesn't recognize them.
    Anyone has an idea of what's happening?
  18. allenskd
    Could be that 1) you are launching the wrong WINE binary, has happened to me in the past. 2) you don't have security libraries installed properly which I in my opinion would be hard to believe with popular distributions. 3) There's something messy with your WINEPREFIX bottle.

    1) Check that you are running the correct binary if what I could think of.

    WINE does ask you at its interval, if you use the same WINE bottle and you have it installed it won't ask you. Most of the time it asks you when you are changing the WINE binary then it starts configuring your bottle again. Note that I don't know how WINE manages old versions of gecko and mono if you jump from (WINE 1.5 to WINE 1.7.30), that's beyond me, maybe it uninstalls the old one? Not sure.


    I've the libraries in Arch Linux and Fedora without a problem... plus it's really hard to know what exactly you are doing without seeing the commands you are running, or if you are setting the correct WINEPREFIX or if you are setting the correct WINE binary.

    Also I recently updated the links to the binaries and source because they didn't work so... I'm not sure how you got the binaries...
  19. darker00
    I found the package on an old article on your blog (the link you updated it's that I'm using to download wine).
    The commands I input in my terminal are the commands in this guide. The paths are the same (except the fact my home obviously has a different name than yours).
    I don't have any wine version installed on my pc, except this one (the command wine --version returns 1.7.24).
    I'll try to reinstall everything and check again if I'm doing something wrong.

    Thanks for the help ;)

Share This Page