1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Harry Potter Sorcerer's Stone Guide

Discussion in 'Guides' started by booman, Mar 10, 2017.

  • by booman, Mar 10, 2017 at 12:28 PM
  • booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Dec 17, 2012
    Likes Received:
    Trophy Points:
    Linux, Arizona
    Home page:

    Play as Harry Potter in The Sorcerer's Stone in an adventure, platformer and Quidditch flying game. Meet many of the famous Wizards and characters from the movies. Hop your way through linear levels and use your magic to find secrets and conqueror your enemies.


    Follow my step-by-step guide on installing, configuring and optimizing Harry Potter And The Sorcerer's Stone in Linux with PlayOnLinux.

    Note: This guide applies to the Retail version of Harry Potter And The Sorcerer's Stone. Other versions may require additional steps.

    Tips & Specs:

    To learn more about PlayOnLinux and Wine configuration, see the online manual: PlayOnLinux Explained

    Mint 17.3 64-bit
    PlayOnLinux: 4.2.10
    Wine: 1.8.5

    Wine Installation

    Click Tools
    Select "Manage Wine Versions"

    Look for the Wine Version: 1.8.5
    Select it
    Click the arrow pointing to the right

    Click Next

    Downloading Wine


    Downloading Gecko


    Wine 1.8.5 is installed and you can close this window

    PlayOnLinux Setup

    Launch PlayOnLinux
    Click Install

    Click "Install a non-listed program"

    Click Next

    Name the virtual drive: harrypotter
    Click Next

    Check all three options:
    • Use another version of Wine
    • Configure Wine
    • Install some libraries
    Click Next

    Select Wine: 1.8.5
    Click Next

    Select "32 bits windows installation"
    Click Next

    Wine Configuration

    Applications Tab
    Windows version: Windows 7
    Click Apply

    Graphics Tab
    Check "Automatically capture the mouse in full-screen windows"
    Check "Emulate a virtual desktop"
    Desktop size: 1024x768
    Click OK

    PlayOnLinux Packages (DLL, Libraries, Components)

    Check the following:
    • POL_Install_corefonts
    • POL_Install_d3dx9
    • POL_Install_tahoma
    Click Next

    Installing Harry Potter

    Click "Select another file"
    Click Next

    Click Browse

    Navigate to the Harry Potter CD ROM
    Select "Setup.exe"
    Click Open

    Click Next again...

    Enter the Key
    Click OK

    Click Next

    Click Next

    Click Yes

    Click Next

    Click No

    Click "Register Later"

    Click OK

    Click OK

    PlayOnLinux Shortcut

    Select "HP.exe"
    Click Next

    Name the shortcut: Harry Potter Sorcerer's Stone"
    Click Next

    Select "I don't want to make another shortcut"
    Click Next

    PlayOnLinux Configure

    Select "Harry Potter"
    Click Configure

    General Tab
    Wine version: 1.8.5

    Note: Click the + to download other versions of Wine. Click the down-arrow to select other versions of Wine.

    Display Tab
    video memory size: Enter the amount of memory your video card/chip uses

    Launching Harry Potter
    Select "Harry Potter"
    Click Run

    Note: Click Debug to see bugs and errors

    Click Options

    • Resolution
    • Color Depth
    • Texture Detail
    • Object Detail

    Custom Resolution

    Unfortunately the game only supports 1024x768 from the in-game menu
    We can manually set the resolution ourselves as long as its a 3:4 ratio

    Launch the game at least one time
    Nativate to:
    /home/username/Documents/Harry Potter/
    Open HP.ini
    Update the WxH resolutions in both of these sections:

    You can set the games resolution as high as 1600x1200 and 32-bit color
    Fullscreen - Set your Linux Desktop to 1600x1200 before launching


    Harry Potter the Scorcerer's Stone played really well on my GeForce GTX 950. It should run on just about any laptop since it's an older game. It was nice that 1600x1200 was supported, but had to be adjusted manually.

    Gameplay Video:









  • Categories:


Discussion in 'Guides' started by booman, Mar 10, 2017.

  1. mrdeathjr28
    Very good old harry potter game and good screens too

    However chamber of secrets, i remember have problems with mouse input

  2. Andrew Hanson
    I went through this process using PlayOnMac, which I assume is the same as above, but the game doesn't run. An error message says to insert the correct CD in the CD-ROM (which I did not remove after installing successfully), and then another message pops up saying "Error in Main. Harry Potter Sorcerer's Stone has crashed." The one thing I was not able to implement directly from this guide was the video chip memory, as the number that my MacBook uses was not listed (1536, I believe). Can someone help me?
    booman likes this.
  3. booman
    Sure, I've seen this problem before as well. Wine always has a problem recognizing CD ROM and DVD drives.
    One thing you can try is open configure, then go to the Wine Tab
    Click Wine configuration
    Then check the "drives" Tab and see if it has a CD ROM setup.
    If not, you can create one and make sure it is set as the "D" drive

    Then eject your Disk and re-enter it. Try the game again.
    I don't remember if this game requires the disk in the drive to play, but normally I will copy all of the data off the disk to a folder on the desktop and install it from there.
  4. Andrew Hanson
    I tried setting a CD-ROM to the D drive in the Configuration (Drives tab) as you suggested, but that didn't work. I also tried copying all the data from the disk to a folder on the desktop and installing it from there, but that didn't work either. I still get the same error. Thanks for your help!
    booman likes this.
  5. booman
    Hmm, what version of PlayOnMac are you using? 4.3.4 is the current version.
    Maybe you should try an older version like 3.0 or even 2.0
    This is always a problem with CD ROM games. I think there is a DRM tied to the CD ROM and the game requires the disk in the drive to play. Sadly...

    Also, maybe Mac has the same problem as Linux with unmounting disks...
    I have to unmount the disk before removing the CD from the drive. Otherwise, if I just eject and grab the disk, Linux still thinks its mounted for some reason?
  6. ickdya
    My game is running super fast, the movies are so fast that stuff gets skipped, the timers are a bit faster, and I and every other npc is zumming around the map.
    booman likes this.
  7. booman
    Hi, did you post on the YouTube video as well?
    Did you follow all the instructions in this guide?

    I have never experienced a game running too fast with Wine. I have seen it in DOSBox, but not Wine.

    What version of PlayOnLinux are you running?
    ickdya likes this.
  8. ickdya
    yes, that was me on the youtube
    I am using PlayOnLinux 4.2.10 as seen in the help menue.
  9. ickdya
    Okay i just reinstalled the poe or what ever for fun, it fixed the probblem, but it came back -slowly. I was at the 1st herbolgy clase, were I learn the incindio spell. I was were I met the 1st blue butterfly thing, were the vines were attacking the tree, by the time I got melfory and the chase for the remball, after like 2 or so retrys, it had sped back up to the super speed mode. I fear later on in the game, this speed hike will make it almost enbeatable.
  10. booman
    Very strange for sure!
    Make sure to download the newest version of PlayOnLinux: 4.3.4
    Then download Wine 4.0 with the Wine manager. That might help...
  11. ickdya
    So with the newest version of whin Hq it installs and plays just fine, no need to tweek or anything.
    I even had luck runng it from the play on linux install folder. Yet for some resion I could not get your methode to worke. I am on mint cinnom 18 by the by
    booman likes this.
  12. booman
    Interesting. Probably because of the PlayOnLinux version.
    The older versions have unsupported versions of Wine.

    Thank you for posting your solution!

Share This Page