1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installing Guild Wars 2

Discussion in 'PlayOnLinux' started by booman, Apr 24, 2014.

  1. allenskd

    allenskd Active Member

    Joined:
    Feb 5, 2014
    Messages:
    510
    Likes Received:
    51
    Trophy Points:
    28
    GW2 is known to be CPU-bound and can be pretty heavy... if you are still on dual core there's a high chance you need to upgrade.

    As for the changes I did I was using the latest CMST patches from Stefan's github and I also added a patch to solve the mouse problem. Remember to enable CSMT in your registry and disable StrictDrawOrdering. I haven't found the build on my HDD yet, need to look for it later on today.
  2. allenskd

    allenskd Active Member

    Joined:
    Feb 5, 2014
    Messages:
    510
    Likes Received:
    51
    Trophy Points:
    28
    Ah ha! I knew I uploaded it to my Dropbox a year ago, wasn't sure it was still there. If you look through my post history at some point you'll see me talking about guild wars 2 setup. (I can't give instructions right now, gtg)

    Here's the link!

    https://dl.dropboxusercontent.com/u/37705/wine-1.7.18-CSMT-GW2.7z

    You will need 7zip to extract it and remember that this is a 32bit build.
    vashin likes this.
  3. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,511
    Likes Received:
    542
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    Could be, my AMD Phantom II 3-core should handle it fine, not sure what he has...
    By the way, check the homepage, I posted the guide this morning
  4. giffmemana

    giffmemana Member

    Joined:
    Jul 23, 2015
    Messages:
    48
    Likes Received:
    5
    Trophy Points:
    8
    Pretty much what I did when I installed it. I guess I just need better hardware
  5. MajorLunaC

    MajorLunaC Member

    Joined:
    Nov 29, 2014
    Messages:
    30
    Likes Received:
    3
    Trophy Points:
    8
    Oops, I lost track of this.

    Yeah, in general disabling StrictDrawOrdering helps with FPS in many games. You can always fiddle with some of the more useful registry keys that have been collected over the years in "UsefulRegistryKeys" (I think PlayOnLinux has the options somewhere?):

    http://wiki.winehq.org/UsefulRegistryKeys
  6. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,511
    Likes Received:
    542
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
  7. Vale

    Vale New Member

    Joined:
    Jul 1, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    allenskd Thank you!!!! I tried to get Guildwars work well since 2 Years!! With your Prefix it works good!! its just 40fps but it is playable thank you! What have you done with the prefix?
  8. Aryvandaar

    Aryvandaar Active Member

    Joined:
    Jun 21, 2014
    Messages:
    304
    Likes Received:
    28
    Trophy Points:
    28
    Location:
    Norway
    @giffmemana Your CPU is pretty old. I don't think you can expect much better performance in GW 2 with your current CPU. Remember that 3 Ghz back in 2009 definitely isn't 3 Ghz now, and the processor will be lacking many features that newer CPU has that increases performance.

    Also, Nvidia GT cards aren't suited for playing newer games, and in general GT series Nvidia cards aren't suited for gaming. You should have a GTX card unless you play 2D games or really old 3D games.
  9. allenskd

    allenskd Active Member

    Joined:
    Feb 5, 2014
    Messages:
    510
    Likes Received:
    51
    Trophy Points:
    28
    Glad to hear! Sorry for the super long reply! I hope you are enjoying the new content in GW2 as well.

    As for the prefix? It's WINE with CSMT straight from Stefan Dösinger's git (the person working on CSMT). I also manually added a patch to fix a mouse wall bug which would prevent you from moving the camera.

Share This Page