1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Renegade X Guide

Discussion in 'Guides' started by booman, Nov 7, 2014.

  • by booman, Nov 7, 2014 at 12:51 PM
  • booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,394
    Likes Received:
    535
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    Renegade X is inspired by Command and Conquer but now you are playing as a sole unit in a first person shooter perspective. Choose to play as GDI or Brotherhood of Nod and battle in huge multi-player arena's in vehicular combat.

    renegadex81.png

    renegadex91.png

    Follow my step-by-step guide on installing, configuring and optimizing Renegade X in Linux with PlayOnLinux.

    Note: This guide applies to the UDK version of Renegade X. Other versions may require additional steps.

    Tips & Specs.:

    To learn more about PlayOnLinux and Wine configuration, see the online manual: PlayOnLinux Explained

    Mint 17 64-bit
    PlayOnLinux: 4.2.5
    Wine: 1.6.2

    Wine Installation

    Click Tools
    Select "Manage Wine Versions"
    wine01.png

    Look for the Wine Version: 1.6.2
    Note: Try using stable Wine 1.8 and 1.8-staging

    Select it
    Click the arrow pointing to the right
    wine02.png

    Click Next

    Downloading Wine
    wine04.png

    Extracting

    Downloading Gecko
    wine05.png

    Installed
    wine06.png

    Wine 1.6.2 is installed and you can close this window

    Download Renegade X
    Download from a local mirror here: http://renegade-x.com/download.php
    or
    Here: https://renegade-x.com/files/file/1-renegade-x/

    PlayOnLinux Setup

    Launch PlayOnLinux
    Click Install
    renegadex01.png

    Click "Install a non-listed program"
    renegadex02.png

    Click Next

    Select "Install a program in a new virtual drive"
    Click Next
    renegadex04.png

    Name your virtual drive: renegadex
    Click Next
    renegadex05.png

    Check all three options:
    • Use another version of Wine
    • Configure Wine
    • Install some libraries

    Click Next
    renegadex06.png

    Select Wine 1.6.2
    Click Next
    renegadex07.png

    Select "32-bits windows installation"
    Click Next
    renegadex09.png

    Wine Configuration

    Applications Tab
    Windows version: windows 7
    Click Apply
    renegadex10.png

    Graphics Tab
    Check "Automatically capture the mouse in full-screen windows"
    Check "Emulate a virtual desktop"
    Desktop size: 1920x1080 (match your Linux desktop)
    Click Ok
    renegadex11.png

    PlayOnLinux Packages (DLL's, Libraries, Components"
    • POL_Install_corefonts
    • POL_Install_dxfullsetup
    • POL_Install_dotnet40
    • POL_Install_msxml3
    • POL_Install_tahoma
    • POL_Install_vcrun2005
    • POL_Install_vcrun2008
    • POL_Install_vcrun2010
    • POL_Install_xact_jun2010

    Click Next
    renegadex12.png

    Note: All packages will automatically download and install

    Installing Renegade X

    Click Browse
    renegadex13.png

    Select "RenegadeX-OpenBeta3a.exe"
    Click Open
    renegadex14.png

    Click Next

    Click Next

    Click Next

    Check "Don't create a Start Menu folder"
    Click Next

    Uncheck "Create a desktop icon"
    Click Next

    Click Install

    Uncheck "Launch Renegade X"
    Click Finish
    renegadex22.png

    PlayOnLinux Shortcut

    Select "UDK.exe"
    Click Next
    renegadex23.png

    Name your shortcut: Renegade X
    Click Next
    renegadex24.png

    Click Next

    PlayOnLinux Configure

    Back to PlayOnLinux
    Select "Renegade X"
    Click Configure
    renegadex26.png

    General Tab
    Wine Version: 1.6.2
    Note: Click the + to download other versions of wine. Click the down-arrow to select other versions of Wine.
    renegadex29.png

    Display Tab
    Video Memory size: Select the amount of memory your video card/chip uses
    renegadex30.png

    Close Configure

    Renegade X Crash

    Renegade X will crash at the UDK screen every time unless you make this fullscreen change.
    Navigate to:
    Code:
    /home/booman/.PlayOnLinux/wineprefix/renegadex/drive_c/Program Files/Renegade 
    Note: username is where you put your Linux login

    Open UDKSystemSettings.ini in TextEditor
    Type "False" where Fullscreen is at the top of the file
    Click Save
    Close UDKSystemSettings.ini
    renegadex31.png

    Right-click UDKSystemSettings.ini
    Click Permissions Tab
    Make sure all permissions are "Read-only"
    Click Close
    renegadex32.png

    Note: UDK will reset the "False" to "True" if you don't make the file "Read-only"

    Launching Renegade X

    Back to PlayOnLinux
    Select Renegade X
    Click Run
    renegadex33.png

    Note: Click Debug to see errors and bugs

    UDK should launch windowed
    Click "I accept"
    renegadex34.png

    .NET errors
    You will see pop-up errors like this
    Click OK or press Spacebar
    renegadex35.png

    Optimization

    Click Settings
    renegadex36.png
    !IMPORTANT!
    Do not change the windowed/full-screen setting!
    Use Alt+Enter later when the map loads
    Otherwise you might get some crazy artifacts
    renegadex39.png

    Adjust the resolution to match your Linux desktop

    Adjust presets or manually adjust:
    • Anti-Aliasing
    • Texture filters
    • Motion Blur
    • Dynamic Lights
    • Dynamic Shadows
    • Textures
    • Detail level
    • Mesh LOD
    • Effects LOD
    • Shadows
    Click Apply

    Rule of Thumb:
    High settings = More detail, lower frame rates
    Low settings = Less detail, higher frame rates

    Fullscreen:
    Load a single-player level
    When it has fully loaded and you are in-game
    Press Alt+Enter to go fullscreen

    Conclusion:
    To play online, the server browser won't list any active servers, but you can enter an IP address to a hosting server by the Renegade X developers:
    http://renegadexgs.appspot.com/servers.jsp

    The full-screen bug is annoying, but once you get in-game and go full-screen, it runs very nicely. Just make sure to set your "virtual desktop" to match your Linux desktop resolution.

    I don't know why .NET errors every time you launch the game because it still works just fine. I had smooth frame rates with my GeForce 550 Ti in Wine 1.6.2. I tried other newer versions of wine and it still ran fine, but the full-screen bug was still there. I would set "windowed" to "full-screen" and got a huge amount of graphical artifacts.
    renegadex39.png

    The only other bug is when you Exit the game it crashes
    renegadex38.png

    When this happens just Alt+Tab to PlayOnLinux
    Click Configure
    Click Wine Tab
    Click "Kill Processes"

    When dotnet 4.5 is compatible with Wine, I hope these bugs disappear

    Gameplay Video:


    Screenshots:
    renegadex80.png

    renegadex82.png

    renegadex83.png

    renegadex84.png

    renegadex85.png

    renegadex86.png

    renegadex87.png

    renegadex88.png

    renegadex89.png

    renegadex90.png

    renegadex92.png

    renegadex93.png

    renegadex94.png
    Last edited: Feb 16, 2018
    danrok likes this.

Comments

Discussion in 'Guides' started by booman, Nov 7, 2014.

  1. Jeffrey Schiff
    Thank you very much for this. It's very helpful. I'm on Arch Linux (x64). I had a couple problems (some currently resolved, others not) while following your guide.

    • When installing the PlayOnLinux packages, I had an issue with dotnet40. I reinstalled it to make it work.
    • I couldn't get the UDK.exe file to launch, because of an error like "
      ALSA lib dlmisc.c:252:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so" After a lot of Googling, I found this https://bbs.archlinux.org/viewtopic.php?pid=1391227#p1391227
    • Finally, while that got the UDK.exe file to launch, sound does not yet work. I have two audio cards. One ties into my HDMI output and one goes out of my analog output (speakers). I have tried many different combinations of hw:1,0 (which is really what should be used to output audio), tried to sleuth around with aplay -l, and so on, but I haven't figured out how to get sound working yet. If I find out, I'll let you know.
    • By far, this is the simplest guide out there. Just follow this. Who knows how much pain I would have gone through if I didn't know I had to use wine 1.6.2 exactly? WineHQ's AppDB website says similar things about anything higher than wine 1.6.x not working for Renegade X.
  2. booman
    Welcome to the forum!
    The dotnet40 is apparently critical for the game to run, but at the same time there is still some bugs because we aren't using dotnet4.5 but I'm glad you were able to get it installed.

    So you can't get the game to launch at all? I got that Alsa error randomly but didn't seem to affect my game. Since you are using two outputs, you may have to resort to one. I have and HDMI output as well, but do not use it. So I always set my default to analog.
    There is also a very annoying bug with Wine and Pulseaudio. Wine supports Alsa only, but obviously you want to use Pulseaudio in Linux, other wise sound is an absolute pain.
    There is a suggested fix:
    Open /etc/pulse/daemon.conf
    Code:
    change default-fragment-size-msec = 10
    to
    Code:
    default-fragment-size-msec = 5
    This may help with the audio errors or any "buffer_underrun" errors you might get in the future. But make sure to set your default audio to analog (at least that has not failed me yet)

    Feel free to test with other versions of wine like 1.7.30
    I had the most success with 1.6.2
    The only bugs I've experienced is setting fullscreen and the crash when I exit.
    Also, I was not able to join any online matches.
  3. Daerandin
    You're on Arch, you may want to try using only 64-bit virtual drives as long as you are using PulseAudio.

    The workaround you linked to is just a quick and dirty workaround, and it also means that only one application can use the soundcard at a time. For a better setup you may want to check the Arch wiki for using dmix.

    If you use 64-bit virtual drives, then you will not experience the ALSA lib error. I suspect the problem lies with how the PlayOnLinux team compile their Wine versions, since this only affects 64-bit Arch systems (and possibly Arch derivatives) running 32-bit wine versions from PlayOnLinux.

    For those few games where you have to use a 32-bit virtual drive, if it does not work in a 64-bit virtual drive, then you need some workaround. Personally I still use the method you linked to, but I keep the file named .asoundrc.bak (so it is not used most of the time), then I edit PlayOnLinux shortcuts that run 32-bit wine to rename that file to .asoundrc before launching the game, and renaming it back to .asoundrc.bak as the last line of the PoL shortcut script.

    Example from my Batman Arkham games shortcut

    Code:
    #!/bin/bash
    [ "$PLAYONLINUX" = "" ] && exit 0
    mv /home/wolf/.asoundrc.bak /home/wolf/.asoundrc
    source "$PLAYONLINUX/lib/sources"
    export WINEPREFIX="/home/wolf/.PlayOnLinux//wineprefix/Steam_arkham"
    export WINEDEBUG="-all"
    cd "/home/wolf/.PlayOnLinux//wineprefix/Steam_arkham/drive_c/./Program Files/Steam"
    POL_Wine Steam.exe "$@"
    mv /home/wolf/.asoundrc /home/wolf/.asoundrc.bak
    
  4. booman
    Try Daerandin's suggestions, he's always using Arch and has experienced a lot of these problems in the past.
    I only use 32-bit virtual drives because that is what works best in Mint/Ubuntu.
  5. Daerandin
    If you are having problems finding out how to make the example .asoundrc output to your correct sound output, post the output you get from

    Code:
    cat /proc/asound/cards
    And I can write you up a simple .asoundrc for this particular purpose. But if you can get it working with a 64-bit virtual drive then you don't need to do this as it can use PulseAudio without issue.
  6. Jeffrey Schiff
    I really didn't expect all of these responses. I posted so that others who might have been stuck in my situation could have seen that simply reinstalling a few things gets you going in the right direction.

    I really appreciate the help. All of this is free and it's almost too good to believe. I can try a 64-bit virtual drive as well. I wasn't sure if that was going to cause any conflict, so I stuck the guide early on.

    Here's the output of cat /proc/asound/cards

    0 [HDMI ]: HDA-Intel - HDA Intel HDMI
    HDA Intel HDMI at 0xf7a1c000 irq 47
    1 [PCH ]: HDA-Intel - HDA Intel PCH
    HDA Intel PCH at 0xf7a18000 irq 46

    And also, just in case, aplay -l

    **** List of PLAYBACK Hardware Devices ****
    card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
    Subdevices: 0/1
    Subdevice #0: subdevice #0
    card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
    Subdevices: 0/1
    Subdevice #0: subdevice #0
    card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: PCH [HDA Intel PCH], device 0: ALC668 Analog [ALC668 Analog]
    Subdevices: 0/1
    Subdevice #0: subdevice #0

    Thanks!
  7. booman
    Daerandin has had success with 64-bit virtual drives, but I've never had problems with 32-bit virtual drives.
    Every single one of my guides was tested in a 32-bit virtual drive, so in theory, it should work fine. You are able to play correct? Just no audio...
    I think Daerandin's script or the Alsa suggestions will fix it, but may have some side-effects.
  8. Daerandin
    Just to state it again, the .asoundrc workaround will prevent any other applications from playing any sound on the specified sound card while it is in use, only one audio source at a time. So if you decide to use this method, you should revert it once you are done playing so that pulseaudio can function as intended afterwards.

    The DEVICE_NAME in the post you link to, is the name within the brackets from cat /proc/asound/cards

    So if you want to use the HDMI output for sound, then your .asoundrc should look like this

    Code:
     pcm.!default {
      type plug
      slave.pcm {
        @func getenv
        vars [ ALSAPCM ]
        default "hw:HDMI"
      }
    }
    If you instead want to use your speakers, then you simply exchange HDMI with PCH.

    A lot of people would probably argue that it is a better solution to use dmix, but personally I find this to be a very simple and easy workaround. If you edit your 32 bit virtual drive shortcuts like I indicated previously, then this could be automated.
  9. booman
    Maybe its time to do a step-by-step guide on this script. Then you can just link to it
  10. Daerandin
    It's not a script, this is just a configuration file for ALSA.
  11. booman
    gotcha... you have referred to it many times here, might was well do a quick step-by-stepper ;)
  12. Daerandin
    Not such a bad idea. It really is not the best solution, but it is a quick and easy solution to ensure that ALSA is used instead of PulseAudio, and it is easily reverted (just rename or move the file).
  13. booman
    Maybe there is a way you can use a script to enable/disable this configuration file with a click?
  14. Daerandin
    Actually, I have already done that for myself. I have also edited the PlayOnLinux shortcut where I need to use it (just one game really) to make this change automatically when I start the shortcut, and revert it when done.
  15. booman
    That is perfect! I would love to try your guide as well, so I can do some little tweaks like this with only a single shortcut.
    This would be helpful for gamers who are trying to run more than one game in the same virtual drive.
  16. MajorLunaC
  17. booman
    No way!!! Awesome!
    Very good news, thanks for sharing.
    I'll add your links to the guide

    Is there a way to use one of the IP addresses and add it via server browser in-game?
  18. MajorLunaC
    As far as I can tell, the in-game browser just doesn't work. You can go ahead and try to connect via IP through it, but I see that as much more hassle than just typing it in the terminal.

    If you like you can write some small script or program to parse the server info from those online server listings, then put the info in a terminal or whatever gui. I might try to do this in the distant future, but for now, filtering through all 2 populated servers is no hassle.
  19. MajorLunaC
    I know you're excited and all, I was too when I found I could play Beta 3, but you kind of messed up your instructions. I recommend you fix them when you get the chance:

    *First of all, those two external links are BOTH server lists provided by Renegade X developers. Those are the lists that the official and non-official launchers for the game look at for info on the servers. I did NOT make any scripts yet. That second link might look a lot more garbled, but it's still their server listing if you look carefully.

    *Second of all, you still have the following in your instructions: "You will not be able to play any online matches"

    Also, I forgot to mention a couple of important things:

    *Look in UDKGame/Config/UDKGame.ini to set your player name (line 36):

    [DefaultPlayer]
    Name=Player
    Team=1

    *To avoid having to kill the process when you want to quit the game, DO NOT PRESS THE QUIT/EXIT BUTTON IN-GAME! Instead, you can press CTRL+C in the terminal wine is running OR setup wine (run winecfg for me) to launch in a window that has an [X] button you can push instead. winecfg -> Graphics -> Emulate Virtual Desktop -> input your resolution. You can also make the window by running something like the following:
    wine explorer /desktop=RenXRocks,800x600 "C:\Program Files\Renegade X\Binaries\Win32\UDK.exe 62.210.151.7"

Share This Page