1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

trying to update mint

Discussion in 'General Linux Discussion' started by Daniel~, Aug 31, 2023.

  1. Daniel~

    Daniel~ Chief BBS Administrator Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    11,225
    Likes Received:
    161
    Trophy Points:
    63
    Location:
    Greenwater WA
    Home page:
    to install ver new they want me do this:

    E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
    E: _cache->open() failed, please report.\
    how do i\
  2. Gizmo

    Gizmo Chief Site Administrator Staff Member

    Joined:
    Dec 6, 2012
    Messages:
    2,244
    Likes Received:
    159
    Trophy Points:
    63
    Location:
    Webb City, Missouri
    Home page:
    Did you try running;

    dpkg --configure -a

    as it suggests?
  3. Daniel~

    Daniel~ Chief BBS Administrator Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    11,225
    Likes Received:
    161
    Trophy Points:
    63
    Location:
    Greenwater WA
    Home page:
    DO I NEED SU OR ANYTHING ELSE?
  4. Daniel~

    Daniel~ Chief BBS Administrator Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    11,225
    Likes Received:
    161
    Trophy Points:
    63
    Location:
    Greenwater WA
    Home page:
    daniel@daniel-XPS-8950:~$ dpkg --configure -a

    as it suggests?
    dpkg: error: requested operation requires superuser privilege
    Assembler messages:
    Error: can't open it for reading: No such file or directory
    it: Error: can't open suggests? for reading: No such file or directory
    daniel@daniel-XPS-8950:~$
  5. ThunderRd

    ThunderRd Irreverent Query Chairman Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    2,758
    Likes Received:
    87
    Trophy Points:
    48
    Location:
    Northern Thailand, the Land of Smiles
    Home page:
    dpkg needs you to be root, so use su or sudo
  6. Gizmo

    Gizmo Chief Site Administrator Staff Member

    Joined:
    Dec 6, 2012
    Messages:
    2,244
    Likes Received:
    159
    Trophy Points:
    63
    Location:
    Webb City, Missouri
    Home page:
    sudo dpkg --configure -a
  7. Daniel~

    Daniel~ Chief BBS Administrator Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    11,225
    Likes Received:
    161
    Trophy Points:
    63
    Location:
    Greenwater WA
    Home page:
    Like So?
    daniel@daniel-XPS-8950:~$ sudo dpkg --configure -a
    [sudo] password for daniel:
    Setting up distro-info (1.1ubuntu0.1) ...
    Setting up libgbm1:amd64 (23.0.4-0ubuntu1~22.04.1) ...
    Setting up libgbm1:i386 (23.0.4-0ubuntu1~22.04.1) ...
    Setting up libunwind8:amd64 (1.3.2-2build2.1) ...
    Setting up libunwind8:i386 (1.3.2-2build2.1) ...
    Setting up libgpgme11:amd64 (1.16.0-1.2ubuntu4.1) ...
    Setting up xxd (2:8.2.3995-1ubuntu2.10) ...
    Setting up libxatracker2:amd64 (23.0.4-0ubuntu1~22.04.1) ...
    Setting up libpoppler118:amd64 (22.02.0-2ubuntu0.2) ...
    Setting up vim-common (2:8.2.3995-1ubuntu2.10) ...
    Setting up libglapi-mesa:amd64 (23.0.4-0ubuntu1~22.04.1) ...
    Setting up libglapi-mesa:i386 (23.0.4-0ubuntu1~22.04.1) ...
    Setting up poppler-utils (22.02.0-2ubuntu0.2) ...
    Setting up libpoppler-cpp0v5:amd64 (22.02.0-2ubuntu0.2) ...
    Setting up libosmesa6:amd64 (23.0.4-0ubuntu1~22.04.1) ...
    Setting up libosmesa6:i386 (23.0.4-0ubuntu1~22.04.1) ...
    Setting up libpoppler-glib8:amd64 (22.02.0-2ubuntu0.2) ...
    Setting up libgpgmepp6:amd64 (1.16.0-1.2ubuntu4.1) ...
    Setting up libgl1-mesa-dri:amd64 (23.0.4-0ubuntu1~22.04.1) ...
    Setting up libgl1-mesa-dri:i386 (23.0.4-0ubuntu1~22.04.1) ...
    Setting up vim-tiny (2:8.2.3995-1ubuntu2.10) ...
    Setting up libegl-mesa0:amd64 (23.0.4-0ubuntu1~22.04.1) ...
    Setting up libegl-mesa0:i386 (23.0.4-0ubuntu1~22.04.1) ...
    Setting up libglx-mesa0:amd64 (23.0.4-0ubuntu1~22.04.1) ...
    Setting up libglx-mesa0:i386 (23.0.4-0ubuntu1~22.04.1) ...
    Setting up language-pack-en (1:22.04+20230801) ...
    Setting up language-pack-gnome-en (1:22.04+20230801) ...
    Setting up language-pack-en-base (1:22.04+20230801) ...
    Generating locales (this might take a while)...
    Generation complete.
    Setting up language-pack-gnome-en-base (1:22.04+20230801) ...
    Processing triggers for mailcap (3.70+nmu1ubuntu1) ...
    Processing triggers for desktop-file-utils (0.26+mint2+vera) ...
    Processing triggers for hicolor-icon-theme (0.17-2) ...
    Processing triggers for gnome-menus (3.36.0-1ubuntu3) ...
    Processing triggers for libc-bin (2.35-0ubuntu3.1) ...
    Processing triggers for man-db (2.10.2-1) ...
    daniel@daniel-XPS-8950:~$

    New version is now down loading.!!

    Please! no need to thank me, no really! Once again you guys have made me happy!!
  8. Gizmo

    Gizmo Chief Site Administrator Staff Member

    Joined:
    Dec 6, 2012
    Messages:
    2,244
    Likes Received:
    159
    Trophy Points:
    63
    Location:
    Webb City, Missouri
    Home page:
    LOL

    Glad we got you going. :)
  9. Daniel~

    Daniel~ Chief BBS Administrator Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    11,225
    Likes Received:
    161
    Trophy Points:
    63
    Location:
    Greenwater WA
    Home page:
    mint seems a bit twitchy-' more than the usual
    warnings about possible conflicts. I choose update rather than keep, risky i know I'[ll let you know if I come across anything to make me regret my decision
    thanks again,

Share This Page