1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

LAN Gaming - Browsers

Discussion in 'General Linux Discussion' started by booman, Feb 7, 2018.

  1. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    8,151
    Likes Received:
    594
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    I have 6 computers in a LAN and do some gaming with friends.

    All of them have Mint 18.3 64-bit, but of course have some different hardware.

    We play games offline with custom IP addresses like:
    • 10.0.0.1
    • 10.0.0.2
    • 10.0.0.3
    • etc
    So I'll host the game on one and everyone will join the game. But its strange that some games won't see the host in the browser.

    Most games have a direct connect-to-IP option or command, like...

    Source Engine:
    • connect 10.0.0.1
    Unreal Engine:
    • open 10.0.0.1
    The problem is, some Linux boxes refuse to see the host in browser and some games do not have an available console or command to connect-to-IP:
    • Titan Quest
    • MX vs ATV
    • Tony Hawk Pro Skater 3
    • Battlefield 2
    Its totally strange because some do see the host and others don't.

    Are there any suggestions on what I can do to see why some do not see the host in browser?

    I don't think its Wine because I've had success with it and native games.

    All the computers are connected to two switches and can easily join other games like:
    • Insurgency
    • Left4Dead 2
    • The Ship
    • Synergy
    • Half-Life 2 Deathmatch
    • Counter-Strike Source
    • Alien Swarm
    So I know they are all connected and can ping eachother. I even turn off the firewall with:
    • ufw disable
    I'm kinda stumped at this point and would love to revive some of these games for LAN gaming.
  2. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    8,151
    Likes Received:
    594
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    I'm pretty sure that I've posted this elsewhere at GamersOnLinux, but I can't seem to find my post
  3. Gizmo

    Gizmo Chief Site Administrator Staff Member

    Joined:
    Dec 6, 2012
    Messages:
    2,139
    Likes Received:
    135
    Trophy Points:
    63
    Location:
    Webb City, Missouri
    Home page:
    Are you making sure the local firewall is disabled? I've found that on Fedora, even when it says it's off, it isn't always, and manually running 'service iptables stop' or its equivalent resolves the issue. That's what Tony and I have to do when we want to play a round of UT.
  4. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    8,151
    Likes Received:
    594
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    Good point. I don't really know.
    When I run
    Code:
    ufw disable
    The output is "firewall is off and disabled at startup"
    (from memory)

    I can ping back-n-forth to all the Mint computers so I know they are networked together... and some games with a console command allows the game to connect. But it does seem network related where the game browser can't see the server running.
  5. ThunderRd

    ThunderRd Irreverent Query Chairman Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    2,497
    Likes Received:
    82
    Trophy Points:
    48
    Location:
    Northern Thailand, the Land of Smiles
    Home page:
    Isn't 10.0.0.1 always the designation for localhost?
  6. ThunderRd

    ThunderRd Irreverent Query Chairman Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    2,497
    Likes Received:
    82
    Trophy Points:
    48
    Location:
    Northern Thailand, the Land of Smiles
    Home page:
    Never mind my comment, I was thinking of 127.0.0.1
  7. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    8,151
    Likes Received:
    594
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    I used to have my Fedora server host games on 10.0.0.1 and it always worked perfectly, but now I host on my main Mint 18.3 box: 10.0.0.2

    I am required to play offline with these IP addresses because of Steam. The games we play in Steam can do offline multi-player with one single Steam account, thus avoiding 6 Steam accounts and purchasing the game 6 times.
    All the other multi-player games like Magicka, Dead Island, Chivalry: Medieval Warfare and others just won't run multi-player offline. So we don't play those games for now.
  8. booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    8,151
    Likes Received:
    594
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    Looks like I made a mistake with the command:
    Code:
    ufw disable
    I didn't use sudo, so it may have turned back on automatically

Share This Page