1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Magicka Guide

Discussion in 'Guides' started by booman, Oct 18, 2013.

  • by booman, Oct 18, 2013 at 9:37 PM
  • booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Dec 17, 2012
    Likes Received:
    Trophy Points:
    Linux, Virginia
    Home page:
    At first look, Magicka appears to be another run-of-the-mill RPG, but after further investigation you will find an original action game with interesting and demanding strategies.


    Your Wizard will have the ability to control 8 elements with the tap of a button. As you tab the power charges up and you can wield amazing destruction on your enemies, but thats not the end of it... You can combine any of the 8 elements to construct your own combination.
    Want to shoot boulders of fire?
    How about a wall of ice and then electrocute your enemies?
    Shield not enough? Try dropping mines bundled with fire.
    Are you on fire? Put yourself out with water....
    The possibilities are endless... not to mention the physics engine is amazing!

    Follow my step-by-step guide on installing, configuring and optimizing Magicka in Linux with PlayOnLinux.

    Note: This guide applies to the Steam version of Magicka. Other versions may require additional steps.

    Tips & Specs:

    Try SteamPlay before using this guide as Valve now uses a fork of Wine called Proton and should run most Windows games.

    To learn more about PlayOnLinux and Wine configuration, see the online manual: PlayOnLinux Explained

    Mint 14 32-bit
    PlayOnLinux: 4.2.1
    Wine: 1.7.8

    Installing Wine

    Click Tools
    Select "Manage Wine Versions"

    Look for the Wine Version: 1.7.8
    Note: Try using stable Wine 1.8 and 1.8-staging

    Select it
    Click the arrow pointing to the right

    Click Next

    PlayOnLinux will automatically download it and save it in this directory:

    Note: username is where you put your login name

    Its a good idea to backup this directory to another computer because you won't have to keep downloading wine versions when you need them.


    Downloading Gecko


    Wine 1.7.8 & 1.5.18 is installed and you can close this window

    Downloading Steam

    Go To: http://www.steampowered.com
    Click Install Steam

    Do not click "Install Steam Now"
    It will automatically install Linux Steam. Since Magicka isn't made for Linux, we will download the Windows Steam instead.
    click "Windows" under the green button

    Navigate to your desktop
    Click Save

    Setup PlayOnLinux

    Launch PlayOnLinux
    Click Install

    Click "install a non-listed program"

    Click Next

    Select "Install a program in a new virtual drive"
    Click Next

    Name you virtual drive: magicka
    No spaces
    Click Next

    Select all three options:
    • Use another version of Wine
    • Configure Wine
    • Install some libraries
    Click Next

    Select Wine 1.7.8
    (ignore the 1.5 in the screenshot)
    Click Next

    Note: If you are running a 64-bit system, PlayOnLinux will prompt if you want to use a 64-bit or 32-bit virtual drive.
    Always select 32-bit virtual drive.

    Configure Wine

    Applications Tab
    Windows Version: Windows XP
    Click Apply

    Graphics Tab
    Check: Automatically capture the mouse in full-screen windows
    Check: Emulate a virtual desktop
    Desktop size: 1024x768
    Click Ok

    Install Libraries

    Check the following libraries:
    • POL_Install_corefonts
    • POL_Install_directx fullsetup
    • POL_Install_xinput
    • POL_Install_xna 3.1
    Installing Steam

    Click Browse

    Navigate to your desktop
    Select: SteamInstall.msi
    Click Open

    Click Next

    Click Next

    Check: I accept the license...
    Click Next

    Click Next

    Click Next

    Click Install

    Click Finish

    Updating Steam

    More updating, extracting and installing

    When Steam is done installing the login screen will pop up. You probably won't see any text because there is a font bug.
    Even if you "can" see fonts, close Steam so we can continue the PlayOnLinux setup
    Click the "X" to close Steam login

    PlayOnLinux Shortcut

    Select Steam.exe
    Click Next

    Name your shortcut: Magicka Steam
    Click Next

    Select "I don't want to make another shortcut"
    Click Next

    More PlayOnLinux Configuration

    Back to PlayOnLinux
    Click Configure

    Select Steam virtual drive

    Installing dotnet

    General Tab
    Set the Wine version
    Wine version: 1.7.8
    Arguments: -no-dwrite -no-cef-sandbox
    This fixes the missing font and store problem

    Before installing dotnet launch Terminal and run this command
    sudo echo "0" > /proc/sys/kernel/yama/ptrace_scope
    Note: Terminal should require a password. There are some security implications with this command, but it resets to "1" the next time you restart.

    Install Components Tab
    Select dotnet30
    Click Install
    (installs 2.0, sp1, sp2)

    Note: I there are any error, click "OK" on them and start over with dotnet30
    Its critical to have these packages installed because Magicka won't run without them.

    Select dotnet35
    Click Install

    Display Tab
    Direct Draw Renderer: opengl
    Video Memory Size: size of memory on your video card
    Offscreen rendering mode: fbo

    Configuring Registry
    The only reason we are modifying the Registry is because Magicka will automatically try to install dotnet, xna and directx at first launch. It will hang every time. So this Registry fix will eliminate the problem.

    Wine Tab
    Click Registry Editor
    1. Maximize HKEY_LOCAL_MACHINE
    2. Maximize Software
    3. Maximize Valve
    4. Maximize Steam
    Right Click Steamand select New Key
    Name the key: Apps

    Right Click Apps and select New Key
    Name the Key: 42910

    This is what the heiarchy should look like

    Now we are going to create some new REG_DWORD
    Right Click 42910
    Click New
    Click DWORD Value

    Name this DWORD: DirectX

    Double-Click it
    Enter 1 in Value data
    Click OK

    Right Click 42910 again
    Click New
    Click DWORD Value

    Name this DWORD: DotNet

    Double-Click it
    Enter 1 in Value data
    Click OK

    Right Click 42910 one last time
    Click New
    Click DWORD Value

    Name this DWORD: xna

    Double-Click it
    Enter 1 in Value data
    Click OK

    Close the Registry Editor

    Wine Tab
    Click "Windows reboot"
    Steam Will automatically launch, close it because we have one more setting to make.

    General Tab
    Change the Wine version
    Wine version: 1.7.8
    Arguments: -no-dwrite
    This fixes the font problem

    Note: -no-dwrite only works if you launch Steam from PlayOnLinux. Steam is automatically set to launch when Windows starts, which means if you do a "Windows Reboot" from the Wine tab -no-dwrite won't execute. Just close Steam and try again.

    Close Configure

    Installing Magicka

    Back to PlayOnLinux

    Select Magicka Steam
    click Run

    You may see a pop-up error when clicking the Steam icon
    Just click OK

    Select Login to an existing account

    Login to your Steam account

    Select Magicka
    click Install

    Click Next

    Click I Agree

    Click Next

    Click Finish

    Wait while Magicka downloads through Steam

    When its complete you can now launch Magicka
    Click Play

    Note: You shouldn't see any "Performing first time setup.." dialog since we edited the registry

    Magicka might start with a white screen and then crash
    Click Play again
    crash again, but don't give up
    Click Play again

    If you get a warning that its already running, then wait a few seconds and try again.

    I have seen Magicka crash consistently and then play just fine.
    Be patient and determined. It WILL run!

    Magicka is not a super high quality game at any rate. So it should run on laptops, netbooks and even tablets.

    Click Options

    Click Graphics

    Set Resolution, shadows, decal limit, particle effects and particle lights.
    These are the only options you have.
    Wine should be happy with most of these settings with a GeForce card.

    Higher settings = higher detail, lower frame rates
    Lower settings = lower detail, higher frame rates

    I was able to run Magicka at 1680x1050 on my GeForce 550 Ti and it ran beautifully. Once I got past the initial crashing (which I've read is due to alsa audio compatability) it ran without any issue. Frame rates were great, controls and audio almost flawless.
    I did have one issue where the game didn't recognize keyboard input, but a quick Alt+Tab fixed that.
    Last edited: Dec 12, 2019
    graywolf.theheathen likes this.


Discussion in 'Guides' started by booman, Oct 18, 2013.

  1. booman
    High Res Screenshots:
    magicka80.png magicka81.png

    magicka82.png magicka83.png

    magicka85.png magicka86.png

    magicka87.png magicka88.png

    magicka89.png magicka90.png

    magicka91.png magicka92.png

    magicka93.png magicka94.png

    magicka95.png magicka96.png
  2. afd_rulez
    You sir, are a hero. You give the best comprehensive guides for PlayOnLinux. Thank you.
    I finished this guide, and want to check up on a couple of things.
    When i tried to run the command:
    Terminal gave me a "permission denied", so I changed it from POL-->Configure-->General-->Wine Version
    Is that fine?
    Then I got to installing dotnet. dotnet30 was a clean install. However, dotnet35 showed me an error message that I've been getting in the past couple of days (I've been trying [never give up]; using POL's installation). The message said:
    I tried downloading dotnet35 again. I am pretty sure dotnet2sp1 is downloaded, since you mentioned it being part of dotnet30, and I've tried to install independently. I click OK, and I continued. Is that going to affect anything?
    Finally, I wanted to make sure that the crash you were talking about is the same appearing for me. Instead of getting the usual POL crash (with a sad face).
    I get a windows window that says: "magicka has encountered a problem and needs to close. We are sorry for the inconvenience". I press "don't send" for the error report, and another window appears saying: "The program Magicka.exe has encountered a series problem and needs to close. We are sorry for the inconvenience".
    Otherwise, thank you for your guide(s). They were very helpful.
  3. booman
    When you did the "sudo ptrace_scope" command, did it prompt you for a password?
    It doesn't matter which wine version you use, if you want to install dotnet 20-35 it requires this command.

    I've experienced many problems with installing dotnet. The best results I have seen are using Wine 1.5.18
    You can install all of them without errors or crashing, then switch Wine back to a newer version to run your game.

    I'm sure this is the problem with Magicka. Without dotnet, it won't run at all.
    Sorry about the registry hacks, it was such a pain trying to figure those out so it would run on Linux. At least it runs, but such a pain to get it going.
    I try to avoid the registry at all time :cool:
  4. 493pkmns
    Hello. I'm two years late to the party, but yeah... Anyhow, I followed the instructions (clear and effective, thank you very much for that), but once I tried to run Magicka (technically the demo for reasons that don't bear getting into at the moment (yes, I did go back and edit the registry for the correct game ID (73050))), it gave me this error:

    "The original error was:
    Microsoft.Xna.Framework.NoSuitableGraphicsDeviceException: Could not find a Direct3D device that supports the requested features.
    at Microsoft.Xna.Framework.GraphicsDeviceManager.FindBestPlatformDevice(Boolean anySuitableDevice)
    at Microsoft.Xna.Framework.GraphicsDeviceManager.FindBestDevice(Boolean anySuitableDevice)
    at Microsoft.Xna.Framework.GraphicsDeviceManager.ChangeDevice(Boolean forceCreate)
    at Microsoft.Xna.Framework.GraphicsDeviceManager.ApplyChanges()
    at Magicka.Game..ctor()
    at Magicka.Game.get_Instance()
    at Magicka.GlobalSettings..ctor()
    at Magicka.GlobalSettings.get_Instance()
    at Magicka.Program.Main(String[] args)"

    I tried installing DirectX through PoL as a component (d3dx11), but that didn't help. Any help you can offer would be greatly appreciated. I'm not too sure what other information I should give that could be helpful. Sorry.
  5. booman
    If you installed the directx fullsetup packages, then d3dx11 should already be installed.
    In fact, you might want to start over with Steam and only install d3dx9 because Magicka should run just fine on direct X 9.
    Its been a while since I have tested Magicka. I'm not sure of the status of XNA in Wine recently.
    I definitely recommend using a newer version of Wine like 1.7.47 or even the 1.7.47staging versions.
    You might get better results with those Wine versions.
    Let me know if this helps...

    Also make sure you are using PlayOnLinux 4.2.8
  6. Drika
    A bit late for the party, but...Anyway, I've tried to follow your BEAUTIFUL guide and everything seems to work just fine...Exept the fact that, when I try to launch the game, that's what I get (see screenshoot). Any guess?

  7. Drika
    Uhm, the screenshot wasn't there in my other post (and I can't edit it), so here I go with another link. In the mean time I've tried to reinstall completly steam and magicka, but I got the some "error".
    In fact Steam "starts" Magicka (I even got a card yesterday), but all I can see is this kind of screen.
  8. booman
    This is a pretty old guide. I haven't had a chance to test Magicka with newer versions of Wine. What are your specs?
    • distro
    • video card
    • driver version
    • wine version
    • playonlinux version
    I'm re-installing Magicka right now to see how it runs with Wine 1.8
  9. Drika
    Thank you for your answer. I've experimented a bit around and with Wine 1.8 works pretty fine (can't switch back to fullscreen after windowed by mistake, though. Any suggestion?). The only real issue I can see right now is in multiplayer (even if I don't know if it's a steam or wine problem.) I have a pretty bad latency that, in a """"co-op"""" game like magicka is pretty bad.
  10. booman
    I'm Glad you got it working. When I tried Magicka today it kept crashing before the Paradox logo. Then I tried an older version of Wine and it magically worked. I even tried Wine 1.8-staging and it works fine.
    I didn't test Magicka with multi-player online. I've never experienced latency issues with other games online so this might be something unique with Magicka. Have you tried it in a LAN?

    If you are using the virtual desktop, make sure to adjust it to match your Linux Desktop. If you set Magicka to the same resolution as your Linux Desktop, then you might not need the virtual desktop at all. You can try disabling it. Then fullscreen should work. Play around with the settings
  11. Drika
    I haven't, but surely I will. At last I'll know if it's a WIFI problem or what.

    In fact, I'm not. As soon as I'm home, I'll try to play a bit around with settings. Thank you very much!
  12. booman
    No problem. The only problems I had yesterday was the initial launch. I'll test Magicka with Wine 1.9.5 as well. I was able to launch it with the virtual desktop set to 1024x768, but after changing the resolution in-game I had to disable the virtual desktop.

    Magicka ran fine in Wine 1.9.5-staging.

Share This Page