1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Star Trek Online Guide

Discussion in 'Guides' started by booman, Aug 11, 2013.

  • by booman, Aug 11, 2013 at 2:18 PM
  • booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Joined:
    Dec 17, 2012
    Messages:
    7,981
    Likes Received:
    570
    Trophy Points:
    113
    Location:
    Linux, Arizona
    Home page:
    startrek81.jpg

    Star Trek Online is set in the year 2409, thirty years after the events of Star Trek: Nemesis.
    Each character is captain of their own ship and can choose between three factions:
    • Federation
    • Klingon
    • Romulan
    Immerse yourself in sci-fi third person action, tactical space combat and exploring the galaxy in a beautifully rendered world of Star Trek.

    startrek89.jpg

    Follow my step-by-step guide on installing, configuring and optimizing Star Trek Online in Linux with PlayOnLinux.

    Note: This guide applies to the Downloaded version of Star Trek Online. Steam and Arc versions may require additional steps.

    Note: March 2017 Perfect World Entertainment ended support for Windows XP and Direct X 9. This guide no longer applies until we can pursue more testing in Wine.


    Tips & Specs:

    To learn more about PlayOnLinux and Wine configuration, see the online manual: PlayOnLinux Explained

    Mint 17 64-bit
    PlayOnLinux: 4.2.8
    Wine: 1.7.43

    Wine Installation

    Click Tools
    Select "Manage Wine Versions"
    wine01.png

    Look for the Wine Version: 1.7.43
    Note: Try using stable Wine 1.8 and 1.8-staging

    Select it
    Click the arrow pointing to the right
    wine02.png

    Click Next

    Downloading Wine
    wine04.png

    Extracting

    Downloading Gecko
    wine05.png

    Installed
    wine06.png

    Wine 1.7.43 is installed and you can close this window

    Download Star Trek Online Client

    Go To: http://download.perfectworld.com/sto/star_trek_setup.exe
    Save the star_trek_setup.exe in a folder on your desktop
    startrek01.png

    PlayOnLinux Setup

    Launch PlayOnLinux
    Click Install
    startrek02.png

    Click "Install a non-listed program"
    startrek03.png

    Click Next

    Select "Install a program in a new virtual drive"
    Click Next
    startrek05.png

    Name your virtual drive: startrekonline
    Click Next
    startrek06.png

    Check all three:
    • Use another version of Wine
    • Configure Wine
    • Install some libraries
    Click Next
    startrek07.png

    Select Wine 1.7.43
    Click Next
    startrek08.png

    Select "32 bits windows installation"
    Click Next
    startrek09.png

    Wine Configuration

    Applications Tab
    Windows Version: Windows 7
    Click Apply
    startrek10.png

    Graphics Tab
    Check "Automatically capture the mouse in full-screen windows"
    Check "Emulate a virtual desktop"
    Desktop size: 1920x1080 (or enter the resolution of your Linux desktop)
    Click OK
    startrek11.png

    Installing Packages (Components, Libraries, DLL's)

    Check the following:
    • POL_Install_corefonts
    • POL_Install_d3dx9
    • POL_Install_tahoma
    Click Next
    startrek12.png

    Note: All packages will automatically download and install

    Installing Star Trek Online

    Click Browse
    startrek13.png

    Select the star_trek_setup.exe from your desktop folder
    Click Open
    startrek14.png

    Click Next again

    Click OK

    Click Next

    Click "I Agree"

    Click Next

    Uncheck "Create a desktop icon"
    Click Install
    startrek20.png

    Uncheck "Launch Star Trek Online"
    Click Finish
    startrek21.png

    PlayOnLinux Shortcut

    Select "Star Trek Online.exe
    Click Next
    startrek22.png

    Click Next again

    Select "I don't want to make another shortcut"
    Click Next
    startrek24.png

    PlayOnLinux Configure

    Select "Star Trek Online"
    Click Configure
    startrek25.png

    General Tab
    Wine Version: 1.7.43
    startrek26.png

    Note: Click the + to download other versions of Wine, click the down-arrow to select other versions of Wine

    Display Tab
    Video memory size: Enter the amount of memory your video card/chip uses
    startrek27.png

    Close Configure

    Launching Star Trek Online

    Select Star Trek Online
    Click Run
    startrek28.png

    Launcher Update
    startrek29.png

    Log in with your account credentials (or register)
    startrek30.png

    Star Trek Online Launcher will download and patch the entire game: 9 Gigabytes
    startrek31.png

    Click Engage
    startrek32.png

    Cryptic Loading Screen
    When you launch Star Trek Online the first time, you will have to wait about 15-20 minutes
    After that it launches fairly quick

    Login Again
    Sometimes the login will fail and you have to login again
    startrek33.png

    Optimization

    Click Options

    Display Tab
    Adjust windowed or fullscreen
    Adjust refresh rate and antialiasing
    startrek34.png

    Graphics Tab
    Use Render Quality and Graphics Detail sliders to adjust graphics
    Or manually set:
    • Screen
    • Detail
    • Effects
    • Lights
    startrek35.png

    Advanced Tab
    More settings to increase/decrease performance
    startrek36.png

    Rule of Thumb
    High settings = More detail, lower frame rates
    Low settings = Less detail, higher frame rates

    Conclusion:
    Star Trek Online ran really well on my Geforce 550 Ti. I rarely had any issues with loading, controls or diplay settings. The game actually pre-set everything to High and the game is beautiful.
    Every once in a while the mouse would not turn your character/ship completely around, but a quick right-click fixes it.

    Gameplay Video:


    Screenshots:
    startrek80.jpg

    startrek82.jpg

    startrek83.jpg

    startrek94.jpg

    startrek92.jpg

    startrek91.jpg

    startrek86.jpg

    startrek84.jpg
    Last edited: Aug 16, 2017
    wyrde likes this.
  • Categories:

Comments

Discussion in 'Guides' started by booman, Aug 11, 2013.

  1. steve723
    Unfortunately All cryptic games are like that. Perhaps because wine is between gameclient.exe and Cryptics servers. Communication may not be smooth enough. Hopefully next time you play it will initialize quicker. I typically have to wait about 8 minutes. I also use ubuntu.
  2. booman
    Strange because I only had to wait 15 minutes the first time I logged in... after that it was much quicker. Besides games like Drakensang, I'm guessing this is typical for online games.
  3. dem
    Too bad I uninstalled it after this 15min problem (even on Windows, the first launch of the game is pretty long), especially now we canno't install it on ARC anymore... :(

    I would be happy to test it with GSGL disabled, since it seems that it is THE trick on my hardware to play windows game on linux...
  4. Matt
    i tried loading the game, and it got stuck for 15minutes on loading after i had pressed launch then i got bored and left, this was after it was patching for 3 hours, any ideas how to fix this or should i wait it out
  5. booman
    Hi Matt, welcome to the forums.
    Yeah the 3 hour download is ridiculous! But don't delete it yet. There is a chance you can still use the game files without having to download again.

    Dem and I also had to wait 15 minutes for the initial game screen. Not sure why, but Neverwinter was the same way.
    Make sure you have Internet Explorer 8 packages installed because it installs service pack 3 and msxml3 too.
    I think the game launcher uses IE8 capabilities to launch and login. I wish it didn't, but that might be the case.

    Also, next time you launch click "debug" instead of "run" and then a console will appear with the output of errors. Feel free to post it in the PlayOnLinux forums (remember to use code tags) and I'll take a look.

    Also, do you have the Nvidia or AMD proprietary drivers installed?
    Are you using 32-bit or 64-bit Linux?
  6. Matt
    i run 32 bit ubuntu and i dont think i have nvidia or amd, i got it workign after 25 minutes but it takes 25 minutes every time i launch it and is way to laggy to even play, i think it is probably my laptop that makes the game run so badly, thanks for the help anyway, if u ahve any solutions you might suggest please do
    thanks
  7. booman
    What is the model of your laptop? Its gotta have some kind of video chip in it.
    Chances are the laptop is too underpowered for 3D games like Star Trek Online. Are there any other games you "can" play?
  8. Matt
    cant play many games and that is probably the reason why, before i changed this to linux i used to be able to play this game and it was fine but now i play it and it lags way too much
  9. booman
    I'm guessing you had Windows before you installed Linux. Linux can work for "some" gaming on a laptop, but Wine is more CPU intensive because its running Windows processes and Linux processes. Not emulating Windows, but running stuff in the background that native Linux games don't use.
    I have a feeling you can play native games better than Windows games.
    PlayOnLinux and Wine require a bit more tweaking to get a game running. The cool thing with PlayOnLinux is that you can install and run different versions of Wine to test a specific game.

    If you are a hard-core gamer like me and want to run High Quality games in High Resolutions, then you'll need to get a desktop with a beefy video card. Then Linux can play a lot of your PC games. Thats what I use for all of my testing. I have already tested 80+ games and even completed a few: Mirrors Edge, Hard Reset, Psychonauts, Costume Quest, Stacking, Brutal Legend.
    Obviously I spend more time testing than actual playing, but I do have Windows on a few of my machines for those games that just won't work in Linux. I'm hoping to change that in the future.
  10. Matt
    ah ok, i will be getting a new pc soon, if you could suggest one that would cost around £500 that is good, that would be really helpful, i dont really mind about the graphics as long as the game runs to be honest
  11. dem
    There is also a lot of great native linux games available, and not everyone is CPU or graphics card intensive. Humbe Bundle often sells this kind of games.
  12. booman
    Sure, I can definitely recommend a desktop for around $500.00
    You are already saving money since you want to use Linux.
    I will create a private conversation with you about the hardware.
  13. Blze001
    I've run into a problem: I followed all the steps except when I logged in, there was no automatic download started and none of the games have install options available.

    Thoughts?
  14. booman
    Yeah, we've had the same problem too. The browser won't allow you to search for Star Trek either.
    I got it to work, but am not totally sure how Arc knows to install Star Trek Online.
    I had similar problems with Neverwinter also, but somehow it automatically pops up to start the installation.

    I checked the Star Trek Online forum and they imply that the installer is launching but is behind the Arc client.
    Try this after launching Arc Client:
    1. PlayOnLinux Configure
    2. Wine tab
    3. Task Manager
    4. Right click Star Trek Online (Arc client)
    5. Select minimize

    Now can you see the launcher for installing Star Trek Online?
    Note: You may have to start over with the entire process.

    If you can't get this working, I'll have to install it again and verify this problem
    Blze001 likes this.
  15. Blze001
    Progress: I just redid the steps. I think the solution is to make sure you download the Arc Client from the STO page while logged in to your Cryptic account. Now to hope the rest goes smoothly.

    Thanks for the prompt reply, booman. It's nice when someone stays up on their how-to comment section.
  16. Blze001
    Well, closer. It installed and updated just fine, but now when I click "Engage" POL crashes.

    Also, when I just had dx9d3 installed it complained about needing DirectX 9. When I installed the DirectX 9 named package, now Arc causes POL to crash after checking for updates.
  17. booman
    No problem.
    When you say "complained" do you mean the debug? Or was there a pop-up error?
    I only ever install d3dx9 and d3dx10.
    All of those other d3dx9_36, _40, _46, etc are usually installed with the original d3dx9. So you don't have to install them anyways.
    Feel free to post the debug output and it might give us a clue what the problem is.
    Also, make sure to have proprietary video drivers installed and if you are running 64-bit operating system, make sure to install the 32-bit libraries.

    I recommend posting a new thread in our PlayOnLinux section.
  18. Blze001
    Ooooh, I do have 64-bit Mint... that might be the issue. I'll make a new thread if I still have issues.

    As for when it crashes, it updates with no errors at all and I get the "engage" prompt to launch the game, and the POL desktop closes. The Arc client says "checking for updates" then closes the desktop, again with no error.
  19. booman
    Yeah, that is very odd. Sounds like its installed just fine, so don't delete anything yet.
    Since you are using 64-bit OS, you'll definitely need those 32-bit libraries to run games.
    Each Distro is different....

    Ubuntu:
    sudo apt-get update
    sudo apt-get install ia32-libs

    Mint:
    sudo apt-get update
    sudo apt-get install ia32-libs-multiarch
  20. steve723
    I recently upgraded to Trusty Tar (Kubuntu). I had to reinstall STO due to HD failure requiring reinstalling linux and everything to a new HD. I have been using computers since before the PC was invented so you would think I would have thought to backup! O'well as the Vulcans would say -if the were real- those silly emotional humans again not doing things logically. :rolleyes:

    I tried installing the 32 bit library’s.

    Code:
    steve7233@steve7233-HP-Pavilion-dv6-Notebook-PC:~$ sudo apt-get install ia32-libs
    Reading package lists... Done
    Building dependency tree     
    Reading state information... Done
    Package ia32-libs is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:
      lib32z1 lib32ncurses5 lib32bz2-1.0
    
    E: Package 'ia32-libs' has no installation candidate
    steve7233@steve7233-HP-Pavilion-dv6-Notebook-PC:~$

Share This Page