1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wine DXVK - The Future with Vulkan

Discussion in 'News' started by booman, Mar 21, 2018.


Discussion in 'News' started by booman, Mar 21, 2018.

  1. batmanm0b1e
    doesn't it have to say vulkan for graphics? not DX11
  2. booman
    I'm not sure yet because I haven't been able to test a game yet.
    I have a feeling these games won't see Vulkan unless it has compatibility with Vulkan drivers. But you should be able to enable Direct X 11 compatibility in game. Wine is converting Direct X 11 to Vulkan instead of OpenGL
  3. batmanm0b1e
    I have run Kingdom Come: Deliverance game without DXVK, booman I'm just wondering if it has the same glitches it did before. IN DXVK hopfully fixed
    booman likes this.
  4. booman
    Nice! Didn't know it already ran in Wine.

    I tried ABZU and Just Cause 2 last night and still nothing. I'll do some more testing this weekend. I'm having a hard time know if it DXVK is actually working.
  5. batmanm0b1e
    yep me too because theres no good tutorials out
  6. batmanm0b1e
    Here's another video i followed this but i need more games to try out i didn't want to wait for 60GB game get done my internet is not that fast.

  7. Sputnik_tr_02
    Hey booman try this steps. I hope it works for you;

    01- Download "wine-staging-3.5-x86_64.tar.gz" from: https://lutris.net/files/runners/
    Extract it to: /home/your_user_name/.PlayOnLinux/wine/linux-amd64/

    02- Create a 64 bit virtual drive in PlayOnLinux and select "staging-3.5-x86_64" as the wine version, lets assume we name the virtual drive as DXVK

    03- Download "VulkanSDK-" from: https://vulkan.lunarg.com/sdk/home#windows
    and install it into virtual drive

    04- Open virtual drive's directory and put "winevulkan.json" from my archive into: /drive_c/windows/

    05- Open regedit for virtual drive from PlayOnLinux and import "Vulkan_1.reg and Vulkan_2.reg" from my archive

    06- Open PlayOnLinux and select the virtual drive DXVK from configure menu and click on "Make a new shortcut from this virtual drive"
    find "cube" from the list and select it, name the shortcut as "cube_vulkan_test" or something like that and launch it. If it works you will see a spinning cube in a small window, that means vulkan is working.

    07- Assuming vulkan is working, we can install dxvk.
    Open virtual drive's directory and put 64 bit dll's from my archive into: /drive_c/windows/system32/
    and 32 bit dll's into: /drive_c/windows/syswow64/
    You can find latest dxvk dll's from: https://haagch.frickel.club/files/dxvk/latest/

    08- Open Configure Wine for our DXVK wirtual drive from PlayOnLinux and set "d3d11 and dxgi" to native in Libraries tab.
    That's it.

    Attached Files:

  8. batmanm0b1e
    That's sort of the same guide i posted. Thanks for the playonlinux guide i will try Sputnik_tr_02.

    Doesn't 64bit.dll's have to go in wow64 and system32 for 32bit.dll's?

    (07- Assuming vulkan is working, we can install dxvk.
    Open virtual drive's directory and put 64 bit dll's from my archive into: /drive_c/windows/system32/
    and 32 bit dll's into: /drive_c/windows/syswow64/)
  9. Sputnik_tr_02
    I thought the same but apparently this is the correct way. You can also install DXVK for per application. Just place the correct dll files into the folder where the game exe is and set them to native in winecfg.
    Another thing, if you want to enable DXVK hud; click on your game's or steam's (if you are testing a steam game) shortcut in PlayonLinux and hit the Configure button, then in the configuration window select Miscellaneous tab, at the bottom you will see a field that say "Command to exec before running the program" add this line in that field and close the configuration window.

    export DXVK_HUD=devinfo,fps
    That way you can tell if the game really is using DXVK.
    Yesterday I've tested Deus Ex Human Revolution Director's Cut and it was working. Performance was good but there were a lot of stutter. But google says this is the case for the windows also.
  10. batmanm0b1e
    WOW Thank you for making these up. This is awesome.
  11. Sputnik_tr_02
    Hey did you test any games? Today i have tested Far Cry 3, it launches and i can see DXVK hud in the main menu but when i start the game all i can get is black screen and some sound in the background and fps goes down to single digits, it almost freezes the hole system and i have to kill the process manually. I'll report if anything comes up.

    By the way; make sure to disable CSMT in the wine-staging config, i heard it can be problematic with DXVK also same goes for Steam in game overlay.
  12. booman
    Here is a manual installation guide for Lutris and DXVK

  13. batmanm0b1e
    I didn't test any games yet Sputnik_tr_02. I do have Far Cry 3 how long did it take you to download that game in steam.

    booman. I have seen that guide before unfortunately didn't work for me Lutris is buggy to me never got a game working right and always crashes. Its a shame i hear alot of people brag about oh how Lutris is fantastic its crap in my opinion
  14. batmanm0b1e
    Hi Sputnik_tr_02

    I tried your guide i followed everything to a T. But when i tried launching Vulkan cube.exe it gave me an error. vkCreateInstance
  15. booman
    I'm not going to try that guide either.
    But there are some good tips for PlayOnLinux.
    If I ever get a DX11 games actually running in PlayOnLinux, I'll do a Vulkan specific guide
    batmanm0b1e likes this.
  16. Sputnik_tr_02
    Hi. Can you run native vulkan linux games? And what are your pc specs?

    Type vulkaninfo in the terminal and see if any errors shows up.

    My specs are:
    Kubuntu 17.10
    Nvidia GTX 860m - 390.48 drivers from graphics drivers ppa.

    Make sure registry keys imported properly.

    I have done some more testing and F.E.A.R 3 is also working quite well.
    I managed to get Far Cry 3 to get ingame by setting the game to full screen (it was set to borderless) but sound is bugged and game runs really bad.
    S.T.A.L.K.E.R Call of Pripyat drops to dx9 upon launch, apparently when i first test the game it wasn't using DXVK and seems default wine made some progress on dx11.

    I have done all my testing in PlayonLinux following the exact same steps that i wrote in my post, so i don't know why it wouldn't work.
  17. lyr3
    Lazyly awaiting for the Witcher 3 Guide! haha
  18. booman
    Titanfall 2
  19. booman
    Yes, I was playing the vulkan version of Mad Max and it really ran better than the OpenGL version. It ran really nice.

    I have 6 PCs with different configurations and all have Mint 18.3 64-bit
    My main rig is this:
    • AMD 6-core CPU
    • 8 GB DDR3 RAM
    • GeForce GTX 1060 3GB RAM
    • 128GB SSD (OS)
    • 1TB Spindle HD (/home)
    • PlayOnLinux 4.2.12
    • Wine 3.5

Share This Page