1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wine DXVK - The Future with Vulkan

Discussion in 'News' started by booman, Mar 21, 2018.


Discussion in 'News' started by booman, Mar 21, 2018.

  1. Sputnik_tr_02
    @booman @batmanm0b1e

    Hey guys; i have switched the wine version to 3.5 for my DXVK virtual drive in PlayonLinux and it also gave me an error when i try to run cube.exe, it seems wine builds that comes with PlayonLinux does not support vulkan. Make sure to use
    Just extract it to: /home/your_user_name/.PlayOnLinux/wine/linux-amd64/
    and select it in PlayonLinux and give it a try again if you still have the virtual drive.

    By the way i have done some more testing and Hitman Absolution also works really well on my end.
  2. booman
    Nice! Thanks for confirming!

    Did you have to use the dll's?
    • d3d11.dll
    • dxdi.dll
    Did you put them in the root game folder or system32 or system/wow64?
  3. batmanm0b1e
    Sputnik_tr_02 here is my vulkanINFO

    My PC here is
    i7 2600K
    2TB Gaming SSHD cudafire

    Attached Files:

  4. adcdam
    Hi sputnik, i followed your guide to test dxvk in stalker call pf prypiat but when launching the game i get
    unhandled exception ocurred, see log for details,

    in the debug last line say:
    wine: call from 0x7bc7qqb9 to implemented function dxgi.dll.DXGIDID10createDevice, aborting
  5. Sputnik_tr_02
    Yes i used dll's. I put 64 bit d3d11.dll and dxgi.dll into system32,
    and 32 bit d3d11.dll and dxgi.dll into syswow64 (keep in mind that those locations already have fake dll files with the same name so you have to overwrite them) and set them to native with configure wine.

    There are no errors in your vulkaninfo however your vulkan version is older than mine 1.0.61 mine is 1.0.65 but i don't know if that is the problem. Which nvdia driver are you currently using? Mine is 390.48

    Hi, yes Stalker seems to use a mixture of dx10 and dx11. Unfortunately DXVK does not support dx10. Apparently when i first test the game i did not set DXVK properly and it was using regular wine and i got too excited and reported before making sure, that is my favorite game. However if you get the cube.exe running via PlayonLinux you should be good to go for other games. This is the list of games i tried so far:

    - Deus Ex Human Revolution Director's Cut (Steam); runs really good no visual gliches and stutters that i mentioned earlier settles down as you play.
    - F.E.A.R 3 (Steam); runs without problem
    - Far Cry 3 (with no cd crack); runs but with sound issues and performance is really bad
    - Hitman Absolution (Steam); runs really well, some visual gliches in the benchmark but i did not see any problem in game.

    and make sure to enable DXVK Hud, that way you can be sure if the game using DXVK. (You can look at my comment #32 to see how to do that in PlayonLinux)

    Edit: @adcdam you followed the steps in comment #30 right? My earlier steps were not complete. I edited my comments to prevent confusion. Thanks.
  6. batmanm0b1e
    Thanks Sputnik_tr_02 you great and helpful. most all here are helpful that what i like to see Linux games Linux others working together :)

    I got vulkan running in Lutris finally a game got working. I got warframe working with DXVK.

    Things i would like to know tho

    I'm running Linux Mint 18.3 64bit Cinnamon
    Nvidia driver 384.111
    in warframe it said Vulkan version was running 1.0.49

    So I'm wondering how you know which version of Vulkan you need does it go by Nvidia driver version because i tried searching and couldn't find an answer
  7. Sputnik_tr_02
    Yes, vulkan version is determined by the driver. As long as your vulkan version is higher (or same as) than the one that is required by the dxvk then there should be no problem.
  8. batmanm0b1e
    What do you mean i'm lost right now because VulkanSDK- did not work.

    but right now i installed VulkanSDK- and the cube worked now

    But shouldn't that version work as well even vulkan
  9. Sputnik_tr_02
    Strange, yes it should be backward compatible but probably it has something to do with how DXVK works or wine vulkan implementation. Sorry i am also very new to linux and not an expert by any means. But at least we now know that perhaps VulkanSDK version should be same or lover than the vulkan version of the host system (linux).
  10. batmanm0b1e
    I'm new to vulkan aswell. You seem to have it down tho keep it up and we all work together :)
  11. booman
    I will be trying all of this over the weekend!

    Batman - How did you get past the Warframe client update? Mine opens and closes in a loop forever

    Thanks for all the tips!
  12. batmanm0b1e
    Hi booman.

    I used Lutris aah things are looking up for Lutris now a Game works ;)

    1. Download latest Lutris client. Make sure you have an account with them and sign in!

    2. go here click install. https://lutris.net/games/warframe/

    3. Wait for everything to install and you will have to wait for the updater.sh to finish all the way.It's easier if you have the game all downloaded already you can just copy the download folder IN. I'm not sure if you can download it with Windows and then copy to drive paste it in you should be able to but not tested yet.

    If the updater.sh closes just keep trying it did for me but just keep doing it till its all done and with defrag. For me what worked was to close google-chrome and wait for it. although it shouldn't close I'm not too sure the cause.

    I will make Guide to this Soon. I want to see if i can test this method in playonlinux
  13. booman
    Nice, but you know me... I want it to work in PlayOnLinux. I only got to the game menu a few times, but there were bugs. Probably because of Direct X 11.
    Why is Google Chrome running?

    I'm using the Steam version, but maybe I should go with the website version at this point.
  14. batmanm0b1e
    Idk i have always used Google chrome :D i have used chromium before i just like it i always switch back. And it saves all my bookmarks and things
    I'm just weird like that
  15. booman
    I was just wondering why you closed Chrome, when it probably had nothing to do with Warframe and Lutris.

    I thought maybe the Warframe launcher needed Windows Chrome or something...
  16. batmanm0b1e
    well, the updater.sh That the guy made for warframe kept closing for me downloading big download patch for game. 45min it said. but when i minimized it and went to chrome to watch tv show it closes. even when i minimized it and left to make food. came back and saw it closed.

    It could have been my internet at the time maybe not at a consistent speed or drops idk my internet isn't that fast and sharing in the home i live at. But still shouldn't
  17. booman
    Watch Dogs DX11 with Vulkan/Wine

    FEAR 3

    Crysis 3
  18. batmanm0b1e
    i think this guy lies for bf1 booman. Plus he told me what to do and he's using cracked game. he told me exactly what hegot and i tried it and it doesn't work. I think that guy playing on windows just a look a like hahahahaha:rolling:
  19. booman
    Its very possible, but I still can't seem to run ABZU with DXVK in Wine 3.5 or 3.6.
    I'm getting Vulkan errors when running Wine:

    Which tells me Vulkan is not installed or syncing up for some reason.

Share This Page