1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Assassin's Creed 2 Guide

Discussion in 'Guides' started by booman, Oct 1, 2013.

  • by booman, Oct 1, 2013 at 2:03 PM
  • booman

    booman Grand High Exalted Mystic Emperor of Linux Gaming Staff Member

    Dec 17, 2012
    Likes Received:
    Trophy Points:
    Linux, Virginia
    Home page:
    Assassin's Creed II moves from Israel to Italy where we control Ezio Auditore da Firenze. As a young assassin, he learns of his ancestor Altaïr ibn-La'Ahad's and follows in his footsteps.
    Climb almost any structure in Florence, perform stealthy kills, run-n-hide from guards, ride horses, explore and complete quests.



    Follow my step-by-step guide on installing, configuring and optimizing Assassin's Creed II in Linux with PlayOnLinux.

    Note: This guide applies to the Retail & Uplay version of Assassin's Creed II. Other versions may require additional steps.

    Tips & Specs:

    To learn more about PlayOnLinux and Wine configuration, see the online manual: PlayOnLinux Explained

    Mint 17 64-bit
    PlayOnLinux: 4.2.5
    Wine: 1.7.26

    Wine Installation

    Click Tools
    Select "Manage Wine Versions"

    Look for the Wine Version: 1.7.26
    Note: Try using stable Wine 1.8 and 1.8-staging

    Select it
    Click the arrow pointing to the right

    Click Next

    Downloading Wine


    Downloading Gecko


    Wine 1.7.26 is installed and you can close this window

    Download Uplay

    Go to: http://uplay.ubi.com/
    Click "Download Uplay PC"

    Save UplayInstaller.exe to your desktop
    Click Save

    PlayOnLinux Setup

    Launch PlayOnLinux
    Click Install

    Click "Install a non-listed program"

    Click Next

    Select "Install a program in a new virtual drive"
    Click Next

    Name your virtual drive: assassins2
    Click Next

    Check all three options:
    • Use another version of wine
    • Configure Wine
    • Install some libraries

    Click Next

    Select Wine 1.7.26
    Click Next

    Select "32 bits windows installation"
    Click Next

    Wine Configuration

    Applications Tab
    Windows version: Windows 7
    Click Apply

    Graphics Tab
    Check "Automatically capture the mouse in full-screen windows"
    Check "Emulate a virtual desktop"
    Desktop size: 1024x768
    Click OK

    Installing Packages (Libraries, Components, DLL's)

    Check the following:
    • POL_Install_corefonts
    • POL_Install_d3dx9
    • POL_Install_gdiplus
    • POL_Install_msxml3
    • POL_Install_msls31
    • POL_Install_tahoma
    • POL_Install_vcrun2008
    • POL_Install_vcrun2010

    Note: All libraries will automatically download and install.

    Click Next

    Installing Uplay

    Click "Select another file"

    Click Browse

    Navigate to your Desktop
    Select UplayInstaller.exe
    Click Open

    Click Next

    Click OK

    Click Install

    Click Close

    PlayOnLinux Shortcut

    Select "Uplay.exe"
    Click Next

    Name your shortcut "Assassin's Creed II"
    Click Next

    PlayOnLinux Configure

    Back to PlayOnLinux
    Select "Assassin's Creed II"
    Click Configure

    General Tab
    Wine version: 1.7.26
    Note: Click the + to download other versions of Wine. Click the down-arrow to select other versions of Wine.

    Display Tab
    Video memory size: Select the amount of memory your video card/chip uses

    Installing Assassin's Creed II

    Miscellaneous Tab
    click "Run a .exe in this virtual drive"

    Navigate to your Assassin's Creed II CD ROM
    Select "setup.exe"
    Click Open

    Select Language
    Click Next

    Click Next

    Check "I accept the terms..."
    Click Next

    Click Install

    Click Finish

    Close Configure

    Launching Assassin's Creed II

    Select "Assassin's Creed II"
    Click Run

    Looking for updates
    Uplay may get stuck on this and you will have to close it
    Launch Uplay again

    Updating Uplay

    Login to Uplay

    Select "Assassin's Creed II"

    click Play

    Legacy Patch process

    Click Yes

    Select language
    Click Next

    Select "I accept the terms..."
    Click Next

    Click Next

    Click Finish

    Downloading Uplay game files

    Click Skip

    Press Enter


    Click Options

    Click Graphics

    Set the Resolution to match your Linux Desktop
    Adjust Multisampling, Vsync, Environment, Texture, Shadow, Reflection, Character and Post Effects.
    Click Back to apply

    Rule of Thumb:
    High settings = More detail, lower frame rates
    Low settings = Less detail, higher frame rates

    Wine 1.7.24 and newer has fixed the crypt32 problem and now Uplay runs GREAT. So Assassin's Creed II runs great as well.
    I recommend setting Uplay to offline so you don't have to worry about updates breaking your game.
    Last edited: Jan 13, 2016
  • Categories:


Discussion in 'Guides' started by booman, Oct 1, 2013.

  1. booman
    High Res Screenshots:

    assassins80.png assassins81.png

    assassins82.png assassins83.png

    assassins84.png assassins85.png

    assassins86.png assassins87.png

    assassins88.png assassins89.png

    assassins90.png assassins91.png

    assassins92.png assassins93.png

    assassins94.png assassins95.png

    assassins96.png assassins97.png

    assassins98.png assassins99.png

    assassins100.png assassins101.png

    assassins102.png assassins103.png

    assassins104.png assassins105.png

    assassins106.png assassins107.png

    assassins108.png assassins109.png
  2. booman
    This Assassin's Creed Guide has been updated to reflect Wine 1.7.26
  3. mrdeathjr28
    Excelent guide as always, normally assassins creed saga in singleplayer dont show problems, in multiplayer is different but for other reasons like as punkbuster cpu usage, ping and other things

  4. booman
    I never play multi-player, but I did test Brotherhood and it ran fine. I didn't test long enough to see if I was kicked from the server as I have read on WineHQs
  5. ssj2songohan
    Wine 2.0-rc1-staging x86_64 (64Bit-Version)
    Windows Version: Vista

    Installed POL: d3dx9

    GLSL Support: default
    Dirct Draw Renderer: opengl
    Viedo Memory Size: your size
    Offscreen rendering mode: default
    Render target mode lock: default
    Multisampling: default
    Strict Draw Ordering: default

    Ubisoft Overlay: disabled - Game hangs at startup, when enabled
  6. booman
    Awesome! Thanks for the input
  7. ssj2songohan

    Played for several hours now, works :)
    d3dx9 not needed
    also enabled "Enable CSMT for better graphic support" in
    Configure -> Configure WINE -> Tab Staging
  8. booman
    Thanks for the update! I always add d3dx9 as a just-in-case... I know some games do not need it, but its always safe to add it.
  9. curd
    Heya booman. Great guide.
    However, following this to the letter I got the following error, when starting Uplay for the first time.

    This is on Mint Linux 18.2

    [08/13/17 16:21:55] - Running wine-1.7.26 Uplay.exe (Working directory : /home/curd/.PlayOnLinux/wineprefix/assassins2/drive_c/Program Files/Ubisoft/Ubisoft Game Launcher)
    err:module:import_dll Library ncrypt.dll (which is needed by L"C:\\Program Files\\Ubisoft\\Ubisoft Game Launcher\\libcef.dll") not found
    err:module:import_dll Library libcef.dll (which is needed by L"C:\\Program Files\\Ubisoft\\Ubisoft Game Launcher\\upc.exe") not found
    err:module:LdrInitializeThunk Main exe initialization for L"C:\\Program Files\\Ubisoft\\Ubisoft Game Launcher\\upc.exe" failed, status c0000135
    Am I missing some wine components? I'm not a Windows expert, but is seems I'm missing ncrypt.dll. I'm considering adding the crypt32 component, but it doesn't look like that will contain it... Any pointers?
  10. booman
    Hi curd, welcome to the forum.
    That Wine 1.7.26 is pretty old, so go ahead and try a newer version of Wine like 2.13-staging
    I have a feeling the error will dissapear
  11. curd
    Ubiplay.png Hi booman, indeed. Thanks!
    I had tried 2.13 before, but to no avail. 2.13-staging now loads the Ubiplay screen, but it's all black.
    I do see an outline of two fields, and filling in my Ubiplay email and password allow me to continue.
    Then I get a screen where I dont see any text but I do see lots of promotional pictures of Ubisoft games. I Imagine this is a bit like steam, but I can't see an option to launch my installed version of AC2...

    I got my Steam version working on a Mac by editing some .ini files, but I have the impression the Uplay launcher here is a bit different...

    Do I need to install additional components for 2.13-staging to work properly?

    Added a screenshot of the Ubiplay Window
  12. booman
    I haven't tested Uplay in a long time. yes, Uplay is totally different than Steam. Its ridiculous that we have to even run Uplay when playing through Steam.

    It may have something to do with the Windows version. Try setting Wine Configuration to Windows Vista or Windows 7. Then see if Uplay launches...

    These are the packages for Assassins Creed 2, but not neccesarily for Uplay:
    • POL_Install_corefonts
    • POL_Install_d3dx9
    • POL_Install_gdiplus
    • POL_Install_msxml3
    • POL_Install_msls31
    • POL_Install_tahoma
    • POL_Install_vcrun2008
    • POL_Install_vcrun2010
    You may have to add:
    • POL_Install_vcrun2012
    • POL_Install_vcrun2013
    There is a chance it requires vcrun2015 as well, but that requires a few manual steps.
  13. curd
    Wow that was quick :) Didn't even have time to upload a screenshot .
    I installed vcrun2012 and vc2013 - no dice.
    Changed to Windows Vista - Uplay complained it's not compatible with this version.
    Changed to Windows 2008 for the hell of it - no dice.

    It really looks as though some thing is missing. All the images and moving bits are clear; but anything that is text is invisible...
  14. booman
    Did you add the no-dwrite argument for Steam?
    It disables dwrite in Steam, but not sure how it will affect Uplay.
    I'll have to give it a try at home since its been a long time.
  15. curd
    I'm not using Steam itself, sorry for the confusion, I just mentioned that I got the game to run on my Mac within Steam; Here I'm just running it from within POL.
  16. booman
    Oh, do you have the 2 disc retail version?
    I mentioned Steam because if you try to play AC2, Brotherhood or Revelations, it forces you to install and use Uplay on top of Steam.
  17. curd
    OK it works now.
    When I launch; and I get to the screen where I can't see anything, I just click on the Start button; I choose Run; I browse to the folder where Assassins Creed II.exe is, and voila...
    The patch is downloaded and it just works from there.
    Guess this only means I'll have to do this each time, but I guess it'll have to do.
    This Uplay business seems like a lot of user unfriendly corporate business....
  18. booman
    Oh cool, you found a work-around. Yeah, once you get into Uplay and then play Assassins Creed II, you can then set Uplay to Offline. This way you can play without having to update it.

    Did you change anything before trying this?

    I miss the days of simply playing off a CD ROM/DVD, but I know there are more advantages to download/patching a game through a client like Steam. But now everyone has their own client. It is getting ridiculous. I can't keep up with all the different requirements. Even MMORPGS have their own clients.

    Uplay isn't made for Linux or Wine, so it will have a few bugs.
  19. curd
    No I didn't change anything, was just trying as I went :)
    I think Steam isnt too bad. They even try to be multiplatform and so on.

    But this Uplay thing is just a hassle. Anyway, thanks for all your efforts! Keep up the good work.

Share This Page